2382. Flowers Flourish from France

2382. Flowers Flourish from France

Constraints

Time Limit: 1 secs, Memory Limit: 256 MB

Description

Fiona has always loved poetry, and recently she discovered a fascinating poetical form. Tautograms are a special case of alliteration, which is the occurrence of the same letter at the beginning of adjacent words. In particular, a sentence is a tautogram if all of its words start with the same letter.
For instance, the following sentences are tautograms:

 
  • Flowers Flourish from France
  • Sam Simmonds speaks softly
  • Peter pIckEd pePPers
  • truly tautograms triumph

Fiona wants to dazzle her boyfriend with a romantic letter full of this kind of sentences. Please help Fiona to check if each sentence she wrote down is a tautogram or not.

Input

Each test case is given in a single line that contains a sentence. A sentence consists of a sequence of at most 50 words separated by single spaces. A word is a sequence of at most 20 contiguous uppercase and lowercase letters from the English alphabet. A word contains at least one letter and a sentence contains at least one word.
The last test case is followed by a line containing only a single character ` *' (asterisk).

Output

For each test case output a single line containing an uppercase `Y' if the sentence is a tautogram, or an uppercase `N' otherwise.

Sample Input

Flowers Flourish from France 
Sam Simmonds speaks softly 
Peter pIckEd pePPers 
truly tautograms triumph 
this is NOT a tautogram 
*

Sample Output

Y 
Y 
Y 
Y 
N

Problem Source

每周一赛第二场


#include <iostream>
#include <string>
#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <cctype>

using namespace std;

int main () {
	string a;
	while (getline(cin, a) && a != "*") {
		//toupper(a[0]);
		transform(a.begin(), a.end(), a.begin(), ::toupper);
		bool tmp = false; //标记前面一个是不是空格
		bool flag = true;
		for (int i = 1; i < a.size(); i++) {
			if (tmp == true) {  //前面一个是空格
				if (a[i] != a[0]) { //和第一个不等
					//cout<<"false one : "<<a[i]<<endl;
					flag = false;
					break;
				} else {
					tmp = false;
				}
			}

			if (a[i] == ' ') {
				tmp = true;
			}

			if (flag == false)
				break;
		}
		
		if (flag == true)
			cout<<"Y"<<endl;
		else
			cout<<"N"<<endl;
		
	}

	//system("pause");
	return 0;
}


和vs势不两立!!!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值