uva 144 Student Grants(队列模拟过程)

Time Limit: 3000 MS

The Government of Impecunia has decided to discourage tertiary students by making the payments of tertiary grants a long and time-consuming process. Each student is issued a student ID card which has a magnetically encoded strip on the back which records the payment of the student grant. This is initially set to zero. The grant has been set at $40 per year and is paid to the student on the working day nearest to his birthday. (Impecunian society is still somewhat medieval and only males continue with tertiary education.) Thus on any given working day up to 25 students will appear at the nearest office of the Department of Student Subsidies to collect their grant.

The grant is paid by an Automatic Teller Machine which is driven by a reprogrammed tex2html_wrap_inline26 chip originally designed to run the state slot machine. The ATM was built in the State Workshops and is designed to be difficult to rob. It consists of an interior vault where it holds a large stock of $1 coins and an output store from which these coins are dispensed. To limit possible losses it will only move coins from the vault to the output store when that is empty. When the machine is switched on in the morning, with an empty output store, it immediately moves 1 coin into the output store. When that has been dispensed it will then move 2 coins, then 3, and so on until it reaches some preset limit k. It then recycles back to 1, then 2 and so on.

The students form a queue at this machine and, in turn, each student inserts his card. The machine dispenses what it has in its output store and updates the amount paid to that student by writing the new total on the card. If the student has not received his full grant, he removes his card and rejoins the queue at the end. If the amount in the store plus what the student has already received comes to more than $40, the machine only pays out enough to make the total up to $40. Since this fact is recorded on the card, it is pointless for the student to continue queuing and he leaves. The amount remaining in the store is then available for the next student.

Write a program that will read in values of N (the number of students, 1 tex2html_wrap_inline28 N tex2html_wrap_inline28 25) and k (the limit for that machine, 1 tex2html_wrap_inline28 k tex2html_wrap_inline28 40) and calculate the order in which the students leave the queue.

Input and Output

Input will consist of a series of lines each containing a value for N and k as integers. The list will be terminated by two zeroes (0 0).

Output will consist of a line for each line of input and will contain the list of students in the order in which they leave the queue. Students are ordered according to their position in the queue at the start of the day. All numbers must be right justified in a field of width 3.

Sample input

5 3
0 0

Sample output

  1  3  5  2  4


题意: 输入n和k ,n表示人数编号为1--n,k表示最大钱数 。 

    取得钱的数目变化为    1 、2 、 3、 .... 、 k  、  1  、2 、 3、 .... 、 k  ....   

    开始时 人从编号小到大的排队在ATM处取钱 , 取完钱后,若钱 >= 40,那么他就离开,并

且后面的人就取前面人剩下的钱(不为0)(若当前人有a元,他取了b元,a+b>40 那么下一个

取得钱为  a+b-40 且总钱数 < 40 ,而下下一个人取得钱为(b+1)%k+1  而不是  b%k+1)(这儿要注意)

若钱<40,那么他就排到队的最后,等待下一次取钱。

 最后输出 人离开的编号顺序。


#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;
struct node
{
    int no,num;
    void fun(int _no,int _num)
    {
        no=_no,num=_num;
    }
};
int n,k;

void solve()
{
    queue <node> q;
    node a;
    int cur=1,tmp;
    for(int i=1;i<=n;i++)
    {
         a.fun(i,cur);
         if(a.num>=40)  printf("%3d",i);
         else  q.push(a);
         cur=cur%k+1;
    }
    tmp=cur;
    while(!q.empty())
    {
         node c=q.front();q.pop();
         if(c.num+tmp>=40)
         {
              printf("%3d",c.no);
              tmp=c.num+tmp-40;
         }
         else
         {
              c.num+=tmp;
              q.push(c);
              tmp=0;
         }
         if(tmp==0)  tmp=(cur++)%k+1;
    }
    printf("\n");
}

int main()
{
    while(scanf("%d %d",&n,&k)!=EOF)
    {
        if(n==0 && k==0) break;
        solve();
    }
    return 0;
}



                
CCF大数据与计算智能大赛-面向电信行业存量用户的智能套餐个性化匹配模型联通赛-复赛第二名-【多分类,embedding】.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值