hdu 2817 A sequence of numbers(判断是等差还是等比数列)

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2817


Problem Description
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.
 
Input
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
 
Output
Output one line for each test case, that is, the K-th number module (%) 200907.

Sample Input
   
   
2 1 2 3 5 1 2 4 5
 
Sample Output
   
   
5 16
 
Source


这题的输入是一个数列中的前三个数,然后根据输入判断是等差数列还是等比数列,然后求出第n项。
 
需要注意的地方是对结果取摸:A×B%M = ((A%M)*((B%M)%M)
 
最重要是求等比数列的时候: 求幂乘要用二分来乘,否则会TLE



代码如下:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
int a[1000047];
// m^n % k
__int64 quickpow(__int64 m,__int64 n,__int64 k)
{
    __int64 ans = 1;
    while (n > 0)
    {
		if (n & 1) //n%2 == 1
			ans = (ans*m)%k;
		n = n >> 1 ;//n /= 2
		m = (m*m)%k;
    }
    return ans;
} 

int main()
{
	__int64 n ,t, i,j,a,b,c,k,s,q,d;
	while(~scanf("%I64d",&n))
	{
		while(n--)
		{
			s = 0;
			scanf("%I64d%I64d%I64d%I64d",&a,&b,&c,&k);
			if(b-a == c - b)
			{
				d = b -a;
				s = ((a%200907)+(((k-1)%200907)*(d%200907))%200907)%200907;
			}
			else if(b/a == c/b)
			{
				q = b/a;
				s=((a%200907)*(quickpow(q,k-1,200907)))%200907;
			}
			printf("%I64d\n",s);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值