ZOJ 3182 Nine Interlinks(规律)

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3223


"What are you doing now?"

"Playing Nine Interlinks!"

"What is that?"

"Oh it is an ancient game played over China. The task is to get the nine rings off the stick according to some rules. Now, I have got them off, would you like to have a try to get them on?"

Input

The first line of the input contains an integer T (T <= 30), indicating the number of cases.

Each case consists of a simple integer n (1 < n < 30), which is the number of the total rings you need to get on the stick.

At the beginning, all rings are off the stick.

In each step, you can only get one ring on or off by the following rules:

1. You can get the first ring on or off freely at each step.

2. If the ith ring is on the stick, and the 1st, 2nd... (i-1)st rings are off the stick, you can get the (i+1)st ring on or off freely at each step.

Output

For each case, print in a single line the minimum number of steps you need to get n rings on the stick.

Sample Input

2
2
3

Sample Output

2
5

Hint
The first sample: 1 on, 2 on.
The second sample: 1 on, 2 on, 1 off, 3 on, 1 on.


题意:

最开始 每个环都是闭合的,求按照两个规则操作,能打开所有环的最小操作步数:

1、第一个环可以任意选择打开或者关闭;

2、当 1 到  i - 1 个环是闭合的,第i个环是打开的,那么才可以打开第 i + 1 个环;

代码如下:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <malloc.h>
#include <ctype.h>
#include <math.h>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;
#include <stack>
#include <queue>
#include <vector>
#include <deque>
#include <set>
#include <map>
 


long long  a[50],b[50];
int main()
{
	long long t;
	long long y1,y2;
	cin>>t;

	a[1]=1;
	for(long long i=2;i<=30;i++)
	{
		a[i]=a[i-1]*2+1;
	}
	b[1]=1;
	for(long long i=2;i<=30;i++)
	{
		b[i]=a[i]-b[i-1];
		//printf("%lld %lld\n",i,b[i]);
	}
	long long n;
	while(t--)
	{
		cin>>n;
		printf("%lld\n",b[n]);
	} 
	return 0; 
}

代码二:

#include<cstdio>
int main()
{
	int i,f[30];
	f[1]=1;f[2]=2;f[3]=5;
	for( i = 4 ; i <= 30 ; i++ )
	{
		f[i] = f[i-1]+2*f[i-2]+1;
	}
	
	int t,n;
	while(~scanf("%d",&t))
	{
		while(t--)
		{
			scanf("%d",&n);
			printf("%d\n",f[n]);
		}
	}
	return 0 ;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值