Nine Interlinks

"What are you doing now?"

"Playing Nine Interlinks!"

"What is that?"

"Oh it is an ancient game played over China. The task is to get the nine rings off the stick according to some rules. Now, I have got them off, would you like to have a try to get them on?"

Input

The first line of the input contains an integer T (T <= 30), indicating the number of cases.

Each case consists of a simple integer n (1 < n < 30), which is the number of the total rings you need to get on the stick.

At the beginning, all rings are off the stick.

In each step, you can only get one ring on or off by the following rules:

1. You can get the first ring on or off freely at each step.

2. If the ith ring is on the stick, and the 1st, 2nd... (i-1)st rings are off the stick, you can get the (i+1)st ring on or off freely at each step.

Output

For each case, print in a single line the minimum number of steps you need to get n rings on the stick.

 

Sample Input

2 2 3

Sample Output

2 5

Hint
The first sample: 1 on, 2 on.
The second sample: 1 on, 2 on, 1 off, 3 on, 1 on.

分析:一开始所有的环都是off状态,要把他们变成on状态。我们就需要从后往前依次把这些环变成on状态。但是改变环的状态是有条件的,如果你想改变第i个环的状态,那得保证第i-1个环是on状态,i-1前面的所有环是off状态,每次你想改变第i个环的状态都必须满足上述条件,但是改变第一个环是没有条件的,第一个环可以任意改变。

求n个环需要多少步才能变成on状态?

一个求递推式的过程,数组递推式或者函数递归都可以,一样的意思。做的时候,先手算三个环的情况,然后四个环,五个环,你就会发现规律,注意写的时候把每一步写清楚。看看这三组环数之间的关系,很容易就可以写出来。

递归:

#include<iostream>
using namespace std;
int re(int n){ 
	if(n==1) return 1;
	if(n==2) return 2;
	else{
		return re(n-1)+2*re(n-2)+1;
	}
}
int main(){
	  int t,x;
	  cin>>t;
	  while(t--){
	  	cin>>x;
	  	cout<<re(x)<<endl;
	  }
	  return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值