Nine Interlinks(思维)

“What are you doing now?”

“Playing Nine Interlinks!”

“What is that?”

“Oh it is an ancient game played over China. The task is to get the nine rings off the stick according to some rules. Now, I have got them off, would you like to have a try to get them on?”

Input
The first line of the input contains an integer T (T <= 30), indicating the number of cases.

Each case consists of a simple integer n (1 < n < 30), which is the number of the total rings you need to get on the stick.

At the beginning, all rings are off the stick.

In each step, you can only get one ring on or off by the following rules:

  1. You can get the first ring on or off freely at each step.

  2. If the ith ring is on the stick, and the 1st, 2nd… (i-1)st rings are off the stick, you can get the (i+1)st ring on or off freely at each step.

Output
For each case, print in a single line the minimum number of steps you need to get n rings on the stick.

Sample Input
2
2
3

Sample Output
2
5

Hint

The first sample: 1 on, 2 on.
The second sample: 1 on, 2 on, 1 off, 3 on, 1 on.

题目大意
有根木棍,聪明的你要往上面套环,但是套环是有要求的,如果有一个环,那你就随便玩吧,如果有两个,也一样的道理。但是如果有三个的话,必须第一个先下来,第三个再上去,第一个再上去。(按规则办事…按规则办事)
写出多个后就能找出规律了,在放第i个环(i>=3)时,只有第i-1个在上面,剩下的都得下来,
但是我们可以发现规律: a[i]=a[i-1]+2*a[i-2]+1;
有了规律,那递归就很好写了:

#include<stdio.h>
int main()
{
	int n,i,j,a[31]={0,1,2};
	for(i=3;i<=30;i++)
	a[i]=a[i-1]+2*a[i-2]+1;
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	{
		scanf("%d",&j);
		printf("%d\n",a[j]);
	}
	return 0;
}

自我认为递归这玩意,就是多写几组样例来找规律,虽然经常找不出来,但是我们还得要努力啊!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值