Nine Interlinks(找递推规律)

"What are you doing now?"

"Playing Nine Interlinks!"

"What is that?"

"Oh it is an ancient game played over China. The task is to get the nine rings off the stick according to some rules. Now, I have got them off, would you like to have a try to get them on?"

 

 

Input

 

The first line of the input contains an integer T (T <= 30), indicating the number of cases.

Each case consists of a simple integer n (1 < n < 30), which is the number of the total rings you need to get on the stick.

At the beginning, all rings are off the stick.

In each step, you can only get one ring on or off by the following rules:

1. You can get the first ring on or off freely at each step.

2. If the ith ring is on the stick, and the 1st, 2nd... (i-1)st rings are off the stick, you can get the (i+1)st ring on or off freely at each step.

 

Output

 

For each case, print in a single line the minimum number of steps you need to get n rings on the stick.

 

Sample Input

 

2
2
3

 

Sample Output

 

2
5

 

Hint


The first sample: 1 on, 2 on.
The second sample: 1 on, 2 on, 1 off, 3 on, 1 on.

题意:给了一个串,串上依次有1,2....n 。我们可以对每个位置进行 on 和 off 的操作。操作格式如下:

          1.任何时间都可以改变第一个位置的状态 on->off      off->on

          2.当第 i 个位置为on时,并且1...(i-1)都为off时,我们可以对 i+1 进行任意的状态改变,on->off, off->on

现在给了n个位置,每个位置初始化都为off,问想要把每个位置都变为on最少需要多少次操作。

思路:看了一遍就准备写搜索,但有感觉没办法写,想了一下猜到了是规律题,就开始画图,找规律。

     经过多次尝试,找到了以下规律:

       1.当 i 是偶数时,num[ i ] = 2 * num[ i-1 ] ;

       2.当 i 是奇数时,num[ i ] = 2 * num[ i-1 ] + 1 ;

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    int dp[100]={0,1,2};
    for(int i=3;i<30;i++)
    {
        if(i&1)dp[i]=2*dp[i-1]+1;
        else dp[i]=2*dp[i-1];
    }

    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        printf("%d\n",dp[n]);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值