POJ 1426-Find The Multiple(bfs)

13 篇文章 0 订阅

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 19272 Accepted: 7813 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111
题意:给一个数n,求其只含有数字0或1的倍数,输出其任意的可行解(答案不唯一

思路:从1开始判断是否为n的倍数,然后乘10或者乘10加1,找到一个退出即可

Ps:要不是这道题在bfs里我都不知道怎么搞。这个题我也不知道怎么回事,用g++交AC,用c++交MLE,saddd

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>

using namespace std;
long long n;
queue<long long >q;
long long bfs()
{
    long long res;
    while(!q.empty())
        q.pop();
    q.push(1);
    while(!q.empty()){
        res=q.front();
        q.pop();
        if(res%n==0)
            return res;
        q.push(res*10);
        q.push(res*10+1);
    }
}
int main()
{
    while(~scanf("%lld",&n)){
        if(n==0) break;
        printf("%lld\n",bfs());
    }
    return 0;
}


评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Rocky0429

一块也是爱

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值