poj-1426 Find The Multiple BFS打表

题目链接

poj-1426 Find The Multiple

题目

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 37783 Accepted: 15777 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source

题意

翻译的比较绕,给一个200以内的正整数,要求在该数的所有倍数中找到一个数,但是每位只能由0或者1组成。

题解

比较奇葩的题,如果不是划分到搜索,根本想不到用搜索来写。。。简单地说,由于在十进制中只能出现1跟0,同时又要求是原数的倍数。所以在数据量特别大的时候要利用字符串,并且完成大数的取模运算。但是该题数据量不大(Discuss有用unsigned long long)用long long即可完美覆盖数据。可以使用bfs搜索所有可能,对单一位而言,下一位有0与1两种可能。所以每次搜索时2步选择即可(同时因为这个特性,完全可以利用dp)。但是实际上在不剪枝的情况下bfs超时,但是由于整体数据很小,只有200个,所以完全可以利用bfs得到200个数据,然后打表解决问题。

bfs部分:

由于答案必定是1与0组合得到的十进制数,所以可以将得到答案的过程看成搜索的过程。首位当然不能是0,所以队列的第一位当然是1,然后进入bfs函数,拿出头后,首先判断是否取余为0,是则搜索成功(special judge-找出一个即可)。下一位有2种情况——0或者1,那么就将这2种情况分别加入队列,就是:

que.push(n*10);
que.push(n*10+1);

这样,我们最终就能输出一个找到的数据。

由于bfs一定是超时的,所以我们选择打表,输出格式上进行选择,可以在本地上跑这个bfs的算法,生成表,然后将表存放在数组中,即可解决问题。

C++ 生成表数据代码

#include<iostream>
#include<vector>
#include<string>
#include<math.h>
#include<algorithm>
#include<map>
#include<utility>
#include<queue>
#include<memory>
#define TIME std::ios::sync_with_stdio(false)
#define LL long long
#define MAX 310
#define INF 0x3f3f3f3f

using namespace std;

long long bfs(queue<long long> que,int flag){
    while(!que.empty()){
        long long now = que.front();
        que.pop();
        if(now % flag == 0) return now;
        que.push(now*10);
        que.push(now*10+1);
    }
    return 0;
}

int main() {
    TIME;
    for(int i = 1;i < 201;i++){
        queue<long long> que;
        que.push(1);
        long long ans = bfs(que,i);
        cout << "\"" << ans << "\"" << ",";
    }
    cout << endl << "----end" << endl;

    system("pause");
    return 0;
}

这样,我们将输出的数据全部复制,将最后一个","删除后就是表了。

C++ 打表代码 16ms

#include<iostream>
#include<vector>
#include<string>
#include<math.h>
#include<algorithm>
#include<map>
#include<utility>
#include<queue>
#include<memory>
#define TIME std::ios::sync_with_stdio(false)
#define LL long long
#define MAX 310
#define INF 0x3f3f3f3f

using namespace std;

string ans[200] = { "1","10","111","100","10","1110","1001","1000","111111111","10","11","11100","1001","10010","1110","10000","11101","1111111110","11001","100","10101","110","110101","111000","100","10010","1101111111","100100","1101101","1110","111011","100000","111111","111010","10010","11111111100","111","110010","10101","1000","11111","101010","1101101","1100","1111111110","1101010","10011","1110000","1100001","100","100011","100100","100011","11011111110","110","1001000","11001","11011010","11011111","11100","100101","1110110","1111011111","1000000","10010","1111110","1101011","1110100","10000101","10010","10011","111111111000","10001","1110","11100","1100100","1001","101010","10010011","10000","1111111101","111110","101011","1010100","111010","11011010","11010111","11000","11010101","1111111110","1001","11010100","10000011","100110","110010","11100000","11100001","11000010","111111111111111111","100","101","1000110","11100001","1001000","101010","1000110","100010011","110111111100","1001010111","110","111","10010000","1011011","110010","1101010","110110100","10101111111","110111110","100111011","111000","11011","1001010","10001100111","11101100","1000","11110111110","11010011","10000000","100100001","10010","101001","11111100","11101111","11010110","11011111110","11101000","10001","100001010","110110101","100100","10011","100110","1001","1111111110000","11011010","100010","1100001","11100","110111","11100","1110001","11001000","10111110111","10010","1110110","1010100","10101101011","100100110","100011","100000","11101111","11111111010","1010111","1111100","1111110","1010110","11111011","10101000","10111101","111010","1111011111","110110100","1011001101","110101110","100100","110000","100101111","110101010","11010111","11111111100","1001111","10010","100101","110101000","1110","100000110","1001011","1001100","1010111010111","110010","11101111","111000000","11001","111000010","101010","110000100","1101000101","1111111111111111110","111000011","1000" };

int main() {
	int n;
	while (cin >> n) {
		if (n == 0) break;
		cout << ans[n - 1] << endl;
	}
        system("pause");
	return 0;
}
对应着数组输出即可。
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值