POJ-1426-Find The Multiple (BFS +DFS)两种解法

Find The Multiple

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 35878 Accepted: 14986 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

题解:还是一道简单的dfs题,已知n 求m 是n的倍数 ,m(十进制中只有包含0和1 ) 不会超过100个数位。unsigned __int64 可存放结果,包含两条搜索路径,x*10 和 x*10+1 这两条.

当然也可以用BFS来做,见AC2.

AC1

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
bool vis;
int n;
void dfs(unsigned __int64 x,int n,int k)
{
    if(vis) return;
    if(x%n==0)
    {
        printf("%I64u\n",x);
        vis=true;
        return; 
    }
    if(k==19) return;
    dfs(x*10,n,k+1);
    dfs(x*10+1,n,k+1);
}
int main()
{

    while(scanf("%d",&n))
    {

        if(n==0) break;
        vis=false;
        dfs(1,n,0);
    }
    return 0;
}

AC2

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
using namespace std;
int n;
void bfs()
{

    queue<long long > q;
    while(!q.empty())
        q.pop();
    q.push(1);
    while(1)
    {
        long long tmp=q.front();
        if(tmp%n==0)
        {
            cout<<tmp<<endl;
            return;
        }

        q.pop();
        q.push(tmp*10);
        q.push(tmp*10+1);
    }
}
int main()
{


     while(scanf("%d",&n),n)
         bfs();
    return 0;

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值