陈老师的多校联合20140815 ||uvalive 5881 区间处理

https://icpcarchive.ecs.baylor.edu/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=3892

The security of many ciphers strongly depends on the fact that the keys are unique and never re-used. This may be vitally important, since a relatively strong cipher may be broken if the same key is used to encrypt several different messages.

In this problem, we will try to detect repeating (duplicate) usage of keys. Given a sequence of keys used to encrypt messages, your task is to determine what keys have been used repeatedly in some specified period.

Input 

The input contains several cipher descriptions. Each description starts with one line containing two integer numbers M and Q separated by a space. M (1$ \le$M$ \le$1000000) is the number of encrypted messages, Q is the number of queries (0$ \le$Q$ \le$1000000).

Each of the following M lines contains one number Ki (0$ \le$Ki$ \le$230) specifying the identifier of a key used to encrypt the i-th message. The next Q lines then contain one query each. Each query is specified by two integer numbers Bj and Ej1$ \le$Bj$ \le$Ej$ \le$M, giving the interval of messages we want to check.

There is one empty line after each description. The input is terminated by a line containing two zeros in place of the numbers M and Q.

Output 

For each query, print one line of output. The line should contain the string ``OK" if all keys used to encrypt messages between Bj and Ej (inclusive) are mutually different (that means, they have different identifiers). If some of the keys have been used repeatedly, print one identifier of any such key.

Print one empty line after each cipher description.

Sample Input 

10 5
3
2
3
4
9
7
3
8
4
1
1 3
2 6
4 10
3 7
2 6

5 2
1
2
3
1
2
2 4
1 5

0 0

Sample Output 

3
OK
4
3
OK

OK
1
题目大意:给出一段区间判断是否在这一段区间上有重复数字出现

解题思路:用b数组存储a[i]后面与a[i]最近的重复数字的位置

#include <string.h>
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <map>
using namespace std;
map<int,int>p;
const int maxn=1000000+10;
int a[maxn],v[maxn],b[maxn];
int n,m;
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        p.clear();
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        b[n+1]=n+1;
        for(int i=n;i>0;i--)
        {
            b[i]=b[i+1];
            if(p[a[i]])
                b[i]=min(p[a[i]],b[i]);
            p[a[i]]=i;
        }
        while(m--)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(b[x]>y)
                printf("OK\n");
            else
                printf("%d\n",a[b[x]]);
        }
        printf("\n");

    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值