A + B Problem II

来自杭电acm

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 252440 Accepted Submission(s): 48647

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

代码:
#include<iostream>
using namespace std;

#define MAXSIZE 1200

void reverse(char n[])
{
    int len = strlen(n) - 1;
    int temp;
    for (int i = 0; i <= len / 2; i++)
    {
        temp = n[i];
        n[i] = n[len - i];
        n[len - i] = temp;
    }
}

void sum(char num1[], char num2[], char temp[])
{
    int len1 = strlen(num1) - 1;
    int len2 = strlen(num2) - 1;
    int tempLen = 0;

    for (; len1 >= 0 && len2 >= 0; --len1, --len2)
    {
        int sum = num1[len1] + num2[len2] + temp[tempLen] - 3 * '0';
        temp[tempLen] = sum % 10 + '0';
        temp[tempLen + 1] = sum / 10 + '0';
        tempLen++;
    }

    while (len1 >= 0)
    {
        int sum = num1[len1] + temp[tempLen] - 2 * '0';
        temp[tempLen] = sum % 10 + '0';
        temp[tempLen + 1] = sum / 10 + '0';
        ++tempLen;
        --len1;
    }
    while (len2 >= 0)
    {
        int sum = num2[len2] + temp[tempLen] - 2 * '0';
        temp[tempLen] = sum % 10 + '0';
        temp[tempLen + 1] = sum / 10 + '0';
        ++tempLen;
        --len2;
    }
    if (temp[tempLen] == '0')
    {
        temp[tempLen] = '\0';
    }
    else
    {
        temp[tempLen + 1] = '\0';
    }
    reverse(temp);
}

int main(void)
{
    int n;
    char num1[MAXSIZE] = {};
    char num2[MAXSIZE] = {};
    char num3[MAXSIZE] = {};

    cin >> n;
    for (int i = 0; i < n; i++)
    {
        memset(num3, '0', sizeof(num3));
        cin >> num1 >> num2;
        cout << "Case " << i + 1 << ":" << endl;
        sum(num1, num2, num3);
        cout << num1 << " + " << num2 << " = " << num3 << endl;
        if (i + 1 < n)
        {
            cout << endl;
        }
    }
    system("pause");
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值