杭电ACM-A+B problem

topic:

Calculate A + B.   

Input
Each line will contain two integers A and B. Process to end of file.
Output
For each case, output A + B in one line.
Sample Input
1 1
Sample Output
2
 
 
解题思路:
注意题目的each line即可输入任意行的数字,每行两个数,求每行两数之和并按每行一个的形式输出。
 
 
常见错误解法:
#include <stdio.h>
#include <stdlib.h>


int main()
{
    int a,b;
    printf("input two integer(a,b):\n");
    scanf("%d,%d\n",&a,&b);
    printf("a+b=%d\n",a+b);
    return 0;
}
此时你发现程序本身没错,但提交系统错误,原因在于没有理解清楚题目表达的接受任意行数字的输入和输出
正确解法:
#include <stdio.h>
#include <stdlib.h>


int main()
{
    int a,b;
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值