HDU How Many Tables

Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 
题目大意:每次有多组测试数据T,每次先给n,m,表示有1~n个数,有m则关系,接下来m行,每行两个数表示可以分在一类中(分类可传递比如输入1  2和2  3,则1  2  3  都是一类),问每组可分为几类。

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input

  
  
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output

  
  
2 4
以下是代码,并查集基本操作:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<cstdlib>
#include<cmath>
#include<algorithm>
using namespace std;
int t;
int n,m,fa[1002],ans;
int find(int x)
{
	if(fa[x]!=x) fa[x]=find(fa[x]);
	return fa[x];
}
void doit(int x,int y)
{
	int r1=find(x),r2=find(y);
	if(r1!=r2) {fa[r2]=r1; ans--;}
}
int main()
{
	scanf("%d",&t);
	while(t--)
	   {int al;
		scanf("%d%d",&n,&m);
		ans=n;
	    for(int i=0;i<=n;i++) fa[i]=i;
	    for(int i=1;i<=m;i++)
	       {int x,y;
			scanf("%d%d",&x,&y);
		    doit(x,y);
		   }
	    printf("%d\n",ans);
		}
		
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值