How Many Tables
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5
5 1
2 5
Sample Output
2
4
题意:A知道B,B知道C,D知道E,那么A,B,C可以呆在一个表里,D,E必须留在另一个表中。所以至少需要2桌。
1 2认识,2 3认识,4 5认识,所以1 2 3一桌,4 5一桌,需要两桌。
#include<algorithm>
#include<iostream>
#include<cstdio>
using namespace std;
void Merge(int x,int y);
int Find(int m);
int pre[1008];
void Merge(int x,int y)
{
int fx=Find(x);
int fy=Find(y);
if(fx<fy)
pre[fy]=fx;//大的指向小的
else
pre[fx]=fy;
}
int Find(int m)
{
int n=m;
while(n!=pre[n])
n=pre[n];
//pre[m]=n;
return n;
}
int main()
{
int T;
cin>>T;
while(T--)
{
int n,m;
cin>>n>>m;
int i,x,y,sum=0;
for(i=1;i<=n;i++)
{
pre[i]=i;
}
for(i=1;i<=m;i++)
{
cin>>x>>y;
Merge(x,y);
}
for(i=1;i<=n;i++)
{
if(Find(i)==i)
sum++;
}
cout<<sum<<endl;
}
return 0;
}