HDU-1213-Ignatius' birthday

原题
Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5
Sample Output
2
4
题意:
小明生日,有序号为1-n的人客人来参加,他们彼此之间可能相互认识,也可能互不相识,现在要将所有认识的人分在一桌,每一桌都必须是相互认识的人,如果这个人一个人都不认识则单独开一桌,问需要开多少桌?
题解:
可以利用并查集,其主要思想就是把相互之间有关系的个体,并到同一个集合下,对于这道题目就是如果两个人认识则并到一张桌子上。详细注释见代码:
附上AC代码:

#include <iostream>

using namespace std;
int t,n,m,f[1005],a,b,cnt;//f【】记录第i个人认识的人中取其中一个作为其祖先。
//如果有多个人相互认识,只取其中一个作为他们统一的祖先,cnt记录桌子数量
int findf(int i)//递归找到第i个人的祖先
{
    if(f[i]!=i)
        return findf(f[i]);
    return f[i];
}
void setf(int x,int y)//设置关系
{
    int a=findf(x),b=findf(y);
    if(a!=b)//如果x和y的祖先不相同,则令y的祖先就是x的祖先
         f[b]=a;
    else return;
}
int main()
{
    cin>>t;
    while(t--)
    {
        cnt=0;
        cin>>n>>m;
        for(int i=1;i<=n;i++)
        {
            f[i]=i;
        }//初始化每一个人都认识自己,把自己当做自己的祖先
        for(int i=1;i<=m;i++)
        {
            cin>>a>>b;
            setf(a,b);//设置关系
        }
        for(int i=1;i<=n;i++)
        {
            findf(i);
            if(findf(i)==i)//如果此人的祖先就是自己,则需要另开一桌
                cnt++;
        }
        cout<<cnt<<endl;
    }
    return 0;
}


欢迎评论!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值