PAT A1102. Invert a Binary Tree

1102. Invert a Binary Tree (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node from 0 to N-1, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

#include<cstdio>

#include <queue>
#include<iostream>
using namespace std;

const int maxn = 20;

struct Node{
    int lchild;
    int rchild;
    int father;
}n[20];


int Count;
int findFather(int a){
    while(n[a].father!=-1){
        a= n[a].father;
    }
    return a;
}

void levelOrder(int start,int num){
    queue<int> q;
    q.push(start);
    while(!q.empty()){
        int front = q.front();
        q.pop();
        printf("%d",front);
        num--;
        if(num!=0){
            printf(" ");
        }
        if(n[front].lchild!=-1){
            q.push(n[front].lchild);
        }
        if(n[front].rchild!=-1){
            q.push(n[front].rchild);
        }
    }
    printf("\n");
}


void inOrder(int start){
    if(start==-1){
        return;
    }
    inOrder(n[start].lchild);
    
    printf("%d",start);
    Count--;
    if(Count!=0){
        printf(" ");
    }
    inOrder(n[start].rchild);
}

void invertTree(int root){
    if(root == -1){
        return;
    }
    int temp;
    temp = n[root].lchild;
    n[root].lchild = n[root].rchild;
    n[root].rchild = temp;
    invertTree(n[root].lchild);
    invertTree(n[root].rchild);
}

int main(){
    for(int i=0;i<maxn;i++){
        n[i].lchild = n[i].rchild = n[i].father = -1;
    }
    int num;
    scanf("%d",&num);
    Count = num;
    getchar();
    for(int i=0;i<num;i++){
        string a,b;
        cin>>a>>b;
//        scanf("%s%s",&a,&b);
        if(a[0]>='0'&&a[0]<='9'){
            n[i].lchild = a[0]-'0';
            n[n[i].lchild].father = i;
        }else{
            n[i].lchild = -1;
        }
        
        if(b[0]>='0'&&b[0]<='9'){
            n[i].rchild = b[0]-'0';
            n[n[i].rchild].father = i;
        }else{
            n[i].rchild = -1;
        }
    }
    int root = findFather(0);
    invertTree(root);
    levelOrder(root, num);
    inOrder(root);
    printf("\n");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值