poj 3125 Printer Queue (队列)

30 篇文章 0 订阅
28 篇文章 0 订阅

Printer Queue
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3679 Accepted: 1975

Description

The only printer in the computer science students' union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page of output.  

Because some jobs are more important than others, the Hacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest priority,  
and 1 being the lowest), and the printer operates as follows.
  • The first job J in queue is taken from the queue.
  • If there is some job in the queue with a higher priority than job J, thenmove J to the end of the queue without printing it.
  • Otherwise, print job J (and do not put it back in the queue).
In this way, all those importantmuffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that's life.  

Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplifymatters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.

Input

One line with a positive integer: the number of test cases (at most 100). Then for each test case:
  • One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 100) and m is the position of your job (0 ≤ m ≤ n −1). The first position in the queue is number 0, the second is number 1, and so on.
  • One linewith n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.

Output

For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.

Sample Input

3
1 0
5
4 2
1 2 3 4
6 0
1 1 9 1 1 1

Sample Output

1
2
5

Source


队列的基础题,题目的意思就是要求我们按照优先级输入要打印的东西,求要打印需要多久,这道题还可以用优先队列做,这里我是用队列做的,以后再用优先队列写一次,打印是按优先级由高到低的顺序进行的(相同的优先级先来的线打印),用一个循环队列,队列中注意的是要取余运算。
下面是ac的代码:
#include <iostream>
#include <cstdio>
//#include <cmath> //这里用了几种处理方式,用这个头文件,在c++环境下提交没有通过;
inline int fabs(int k)//这种用法还是第一次用,上次看到别人这样写过,类似于预编译,也比较高效
{
    return k<0?-k:k;
}
using namespace std;
//const int maxn=110;//这种写法和下面的也类似,只不过这种只分配一次内存,用的时候才分配,比下面的省内存
#define maxn 110
int a[maxn];
int main()
{
    int t,n,m,front,rear;
    scanf("%d",&t);
    while(t--)
    {
        int cnt=0;
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        front=0,rear=n;//首尾指针;
        a[m]=-a[m];//把输入都定义为负数
        while((rear+1)%maxn!=front)//循环队列
        {
            int k=a[front];//取出队首的优先级,调整队首指针
            front=(front+1)%maxn;
            bool print=true;
            for(int i=front;i!=rear;i=(i+1)%maxn)
                if(fabs(k)<fabs(a[i]))//比较队列,看队里中是否存在优先级更高的打印任务
                {
                    print=false;
                    a[rear]=k;
                    rear=(rear+1)%maxn;
                    break;
                }
            if(print) //若队列中不存在更高优先级的打印任务,则打印优先级为k的任务
            {
                ++cnt;
                if(k<0)//打印的是目标任务
                {
                    cout<< cnt <<endl;
                    break;
                }
            }
        }
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值