POJ - 2478 - Farey Sequence (欧拉函数)


题目传送:Farey Sequence


Farey Sequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13070 Accepted: 5119

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

Source

POJ Contest,Author:Mathematica@ZSU





根据题意,每次递增都是增加当前数的质因子个数,所以明显是欧拉函数打表


AC代码:

#include <map>
#include <set>
#include <cmath>
#include <deque>
#include <queue>
#include <stack>
#include <cstdio>
#include <cctype>
#include <string>
#include <vector>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#define LL long long
#define INF 0x7fffffff
using namespace std;

int n;

const int maxn = 1000005;
LL phi[maxn];  

LL biao[maxn];

void phi_table(int n, LL* phi) {  
    for(LL i = 0; i <= n; i ++) phi[i] = 0;  
    phi[1] = 1;  
    for(LL i = 2; i <= n; i ++) {  
        if(!phi[i]) {  
            for(LL j = i; j <= n; j += i) {  
                if(!phi[j]) phi[j] = j;  
                phi[j] = phi[j] / i * (i - 1);  
            }  
        }  
    } 
    biao[2] = phi[2];
	for(int i = 3; i < maxn; i ++) {
		biao[i] = phi[i] + biao[i-1];
	}    
}  


int main() {
	phi_table(maxn, phi);
//	for(int i = 0; i < 100; i ++) cout << phi[i] << " ";
//	for(int i = 900000; i < 900100; i ++) cout << phi[i] << " ";
//	for(int i = 900000; i < 900100; i ++) cout << biao[i] << " ";
	while(scanf("%d", &n) != EOF) {
		if(n == 0) break;
		printf("%I64d\n", biao[n]);
	}
	return 0;
}








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值