poj1159 Palindrome DP,lcs

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 44186 Accepted: 15050

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source

求最长公共子序列,第一想到的是用二维数组标记,结果内存超了,题目要求65525k ,还要求n <= 5000,开5000*5000的int 数组果断超啊。。。

同学告诉我可以把4个字节的int 改成无符号短整型 2个字节的

unsigned short int a[5001][5001];

结果内存险过 ,呵呵。

这题最好的方法是用滚动数组只需a[2][5001];即可

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
 int a[2][5001];
int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int n,i,j,ii,jj,l;
    while(scanf("%d",&n)!=EOF)
    {
        char  s[5010],rs[5010];
        cin>>s;
        l=strlen(s);
        for(i = 0 ; i < l ; i++)
            rs[i]=s[l-1-i];
        memset(a,0,sizeof(a));
        for(i=0; i<l; ++i)
            for(j=0; j<l; ++j)
            {
                if(s[i]==rs[j])
                    a[(i+1)%2][j+1]=a[i%2][j]+1;
                else
                    a[(i+1)%2][j+1]=max(a[i%2][j+1],a[(i+1)%2][j]);

            }
//        for(int i = 0 ; i < l ; i++)
//            printf("%d ",a[0][l]);
//        puts("");
//        for(int i = 0 ; i < l ; i++)
//            printf("%d ",a[1][l]);
//        puts("");
        printf("%d\n",l-a[l%2][l]);
    }
return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值