poj 1159Palindrome(dp lcs变形)

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 60328 Accepted: 21010

Description

A palindrome (回文) is a symmetrical (匀称的) string, that is, a string read identically (同一地) from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal (最低的) number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed (改变) into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input (投入). The first line contains one integer (整数): the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase (以大写字母印刷) letters from 'A' to 'Z', lowercase (小写字母) letters from 'a' to 'z' and digits (数字) from '0' to '9'. Uppercase and lowercase letters are to be considered distinct (明显的).

Output

Your program is to write to standard output (输出). The first line contains one integer (整数), which is the desired minimal (最低的) number.

Sample Input

5
Ab3bd

Sample Output

2
//用int MLE  改成short就ac了  添加最少字母 其实就是 在给定的字符串里里面找最长的回文串  然后剪掉最长的剩下的就是你要最少补充的了~~~~
最长回文 就是正着读和到着读 最长的公共子序列  恩  就这么简单
#include<stdio.h>
#include<string.h>
#define max(a,b) a>b?a:b
short dp[5001][5001];
char x[5000],y[5000];
int main()
{
    int n;
    int i,j,k;

    while(~scanf("%d",&n))
    {
        scanf("%s",x);
        for(i=n-1,j=0;i>=0;i--)
        y[j++]=x[i];

        dp[0][0]=0;
        for(i=1;i<=n;i++)
        {
            dp[i][0]=0;
            dp[0][i]=0;
        }

        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
        {
            if(x[i-1]==y[j-1])
                dp[i][j]=dp[i-1][j-1]+1;
            else
                dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
        }
        printf("%d\n",n-dp[n][n]);

    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值