HDU1157寻找中位数

Who’s in the Middle

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19381 Accepted Submission(s): 8533

Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this ‘median’ cow gives: half of the cows give as much or more than the median; half give as much or less.

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

Input
* Line 1: A single integer N

  • Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

Output
* Line 1: A single integer that is the median milk output.

Sample Input
5
2
4
1
3
5

Sample Output
3

Hint

INPUT DETAILS:

Five cows with milk outputs of 1..5

OUTPUT DETAILS:

1 and 2 are below 3; 4 and 5 are above 3.


思路

主要需要知道中位数如何求若有n个数,n为奇数,则选择第(n+1)/2个为中位数,若n为偶数,则中位数是第(n/2)个数和第[(n/2)+1]个数的平均值,本例中也即第四个数和第五个数的平均数。
因为题目测试数据明确是奇数,所以偶数例子不用考虑(不过加了也没事)
还有很重要的就是:这个题目是需要多组测试数据的

代码

n为奇数(符合题目)

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
int a[1000001];

int main()
{
    while(cin>>a[0])
    {
    for(int i=1;i<=a[0];i++)
    {
        cin>>a[i];
    }
    sort(a+1,a+a[0]+1);
    cout<<a[a[0]/2+1]<<endl;
    }
    return 0;
}

如果不确定是n是奇数还是偶数的话

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
int a[1000001];

int main()
{
    while(cin>>a[0])
    {
    for(int i=1;i<=a[0];i++)
    {
        cin>>a[i];
    }
    sort(a+1,a+a[0]+1);
    if(a[0]%2!=0)
    cout<<a[a[0]/2+1]<<endl;
    else
    {
        float m;
        m=(a[a[0]/2+1]+a[a[0]/2+2])*1.0/2.0;
        cout<<m<<endl;
    }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值