HDU 5328 Problem Killer (2015 Multi-University Training Contest 4 2015多校联合)

这道题就是给你一列数组。求里边等差或者等比最长的序列长度。比较简单,但是卡数据。就是等比有可能公比是非整数。需要考虑到这一点。然后输入的时候,依次算出公比和公差,然后累加判断就可以了。

Problem Killer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1035    Accepted Submission(s): 397


Problem Description
You are a "Problem Killer", you want to solve many problems. 
Now you have  n  problems, the  i -th problem's difficulty is represented by an integer  ai  ( 1ai109 ).
For some strange reason, you must choose some integer  l  and  r  ( 1lrn ), and solve the problems between the  l -th and the  r -th, and these problems' difficulties must form an AP (Arithmetic Progression) or a GP (Geometric Progression). 
So how many problems can you solve at most?

You can find the definitions of AP and GP by the following links:
https://en.wikipedia.org/wiki/Arithmetic_progression
https://en.wikipedia.org/wiki/Geometric_progression
 

Input
The first line contains a single integer  T , indicating the number of cases. 
For each test case, the first line contains a single integer  n , the second line contains  n  integers  a1,a2,,an

T104,n106
 

Output
For each test case, output one line with a single integer, representing the answer.
 

Sample Input
  
  
2 5 1 2 3 4 6 10 1 1 1 1 1 1 2 3 4 5
 

Sample Output
  
  
4 6
 

Author
XJZX
 

Source

题目传送门:HDU5328 Problem Killer

代码如下:

#include <cstdio>
#include <iostream>
#define N 1000005
int a[N];
int b[N];
float c[N];
int main()
{
    int T,i,j,n,ans1,ans2,ans;
    scanf("%d",&T);
    while(T--)
    {
        ans1=1;
        ans2=1;
        ans=1;
        scanf("%d",&n);
        scanf("%d",&a[0]);
        for(i=1;i<n;i++)
        {
            scanf("%d",&a[i]);
            b[i-1]=a[i]-a[i-1];
            c[i-1]=(float)a[i]/(float)a[i-1];
        }
        if(n==1)
        {
            printf("1\n");
            continue;
        }
        for(i=1;i<n-1;i++)
        {
            if(b[i]==b[i-1])
            {
                ans1++;
                if(ans1>ans)
                    ans=ans1;
            }
            else
                ans1=1;
            if(c[i]==c[i-1])
            {
                ans2++;
                if(ans2>ans)
                    ans=ans2;
            }
            else
                ans2=1;
        }
        printf("%d\n",ans+1);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值