HDU5328-Problem Killer

Problem Killer

                                                                                 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
                                                                                                            Total Submission(s): 2795    Accepted Submission(s): 964


Problem Description
You are a "Problem Killer", you want to solve many problems. 
Now you have  n  problems, the  i -th problem's difficulty is represented by an integer  ai  ( 1ai109 ).
For some strange reason, you must choose some integer  l  and  r  ( 1lrn ), and solve the problems between the  l -th and the  r -th, and these problems' difficulties must form an AP (Arithmetic Progression) or a GP (Geometric Progression). 
So how many problems can you solve at most?

You can find the definitions of AP and GP by the following links:
https://en.wikipedia.org/wiki/Arithmetic_progression
https://en.wikipedia.org/wiki/Geometric_progression
 

Input
The first line contains a single integer  T , indicating the number of cases. 
For each test case, the first line contains a single integer  n , the second line contains  n  integers  a1,a2,,an

T104,n106
 

Output
For each test case, output one line with a single integer, representing the answer.
 

Sample Input
  
  
2 5 1 2 3 4 6 10 1 1 1 1 1 1 2 3 4 5
 

Sample Output
  
  
4 6
 

Author
XJZX
 

Source
 

Recommend
wange2014
 

题意:给你n个数,求等比或者等差数列中最长的区间的长度

解题思路:处理出公差和公比序列,然后用尺取法求解


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;

int n,a[1000009],b[1000009];
double c[1000009];

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            if(i>1)
            {
                b[i]=a[i]-a[i-1];
                c[i]=1.0*a[i]/a[i-1];
            }
        }
        int head=1,rear=1,ma=1;
        while(rear<n)
        {
            rear++;
            while(b[head+1]!=b[rear]&&rear>head) head++;
            ma=max(ma,rear-head+1);
        }
        head=1,rear=2;
        while(rear<n)
        {
            rear++;
            while(c[head+1]!=c[rear]&&rear>head) head++;
            ma=max(ma,rear-head+1);
        }
        printf("%d\n",ma);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值