hdu 2689 Sort it

Problem Description
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.


Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.


Output
For each case, output the minimum times need to sort it in ascending order on a single line.


Sample Input
3
1 2 3
4
4 3 2 1


Sample Output
0

6

给你一个无序数列,让你由小到大排序,看一公交换多少次;

代码:

 

#include <iostream>
#include <string>
#include <cstring>
#include <algorithm>
#include <iomanip>
using namespace std;
int main()
{
	int m,n,i,j,k,p,q,a[1005];
	while(cin>>n)
	{
		for(i=0;i<n;i++)
		    cin>>a[i];
        k=0;
        for(i=0;i<n-1;i++)
           for(j=i+1;j<n;j++)
             if(a[i]>a[j])
                {
                	swap(a[i],a[j]);
                	k++;
                }
        cout<<k<<endl;
	}
	return 0;
	
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值