poj3281 Dining 网络流匹配问题(拆点建图+Edmond-Karp算法)

链接:http://poj.org/problem?id=3281

Dining
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 19183 Accepted: 8556

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers:  NF, and  D 
Lines 2.. N+1: Each line  i starts with a two integers  Fi and  Di, the number of dishes that cow  i likes and the number of drinks that cow  i likes. The next  Fi integers denote the dishes that cow  i will eat, and the  Di integers following that denote the drinks that cow  i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3

Hint

One way to satisfy three cows is: 
Cow 1: no meal 
Cow 2: Food #2, Drink #2 
Cow 3: Food #1, Drink #1 
Cow 4: Food #3, Drink #3 
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

【解析】:

精髓在于拆点建图,再跑一遍网络流模板代码即可。

【代码】:

#include <stdio.h>
#include <string.h>  
#include <iostream>  
#include <algorithm> 
#include <queue>   
#define mset(a,i)  memset(a,i,sizeof(a))
#define S1(n)    scanf("%d",&n)
#define S2(n,m)  scanf("%d%d",&n,&m)
#define P(n)     printf("%d\n",n);
const int INF=0x3f3f3f3f;
using namespace std;

int Map[520][520];
int pre[520];
int n,f,d,end=510;
int bfs(int s,int t)
{
	int vis[520]={0};
	mset(pre,-1);
	queue<int>q;
	q.push(s);
	while(!q.empty())
	{
		int top=q.front();
		q.pop();
		if(top==t)return 1;
		for(int i=1;i<=end;i++)
		{
			if(!vis[i]&&Map[top][i]){
				vis[i]=1;
				pre[i]=top;
				q.push(i);
			}
		}
	}
	return 0;
}
int EK()
{
	int ans=0;
	while(bfs(0,end))
	{
		int minn=INF;
		for(int u=end;pre[u]!=-1;u=pre[u])
			minn=min(minn,Map[pre[u]][u]);
		ans+=minn;
		for(int u=end;pre[u]!=-1;u=pre[u]){
			Map[pre[u]][u]-=minn;
			Map[u][pre[u]]+=minn;
		}
	}
	return ans;
}
int main()
{
	while(~scanf("%d%d%d",&n,&f,&d))
	{
		mset(Map,0);
		for(int j=1;j<=f;j++)Map[0][j+200]=1;
		for(int j=1;j<=d;j++)Map[j+300][end]=1;
		for(int i=1;i<=n;i++)
		{
			Map[i][i+100]=1;//拆点 
			int fi,di,x;
			S2(fi,di);
			while(fi--){
				S1(x);
				Map[x+200][i]=1;
			}
			while(di--){
				S1(x);
				Map[i+100][x+300]=1;
			}
		}
		cout<<EK()<<endl;
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

雪的期许

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值