杭电 1867 KMP连接两个字符串

      悲剧,,已经记不清写这道题写了几天了,,,,总之就是一直不断的wr,,,然后一直不断的找漏洞,,,,刚才才明白,,原来调用KMP函数时,,j的值就是匹配的长度,,,而我之前却在绞尽脑汁的想这么求匹配的长度。。。。。。。这让我情何以堪!!!!!!!!!!用两次KMP,比较一下两次匹配长度即可。题目:

A + B for you again

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1336    Accepted Submission(s): 288


Problem Description
Generally speaking, there are a lot of problems about strings processing. Now you encounter another such problem. If you get two strings, such as “asdf” and “sdfg”, the result of the addition between them is “asdfg”, for “sdf” is the tail substring of “asdf” and the head substring of the “sdfg” . However, the result comes as “asdfghjk”, when you have to add “asdf” and “ghjk” and guarantee the shortest string first, then the minimum lexicographic second, the same rules for other additions.
 

Input
For each case, there are two strings (the chars selected just form ‘a’ to ‘z’) for you, and each length of theirs won’t exceed 10^5 and won’t be empty.
 

Output
Print the ultimate string by the book.
 

Sample Input
  
  
asdf sdfg asdf ghjk
 

Sample Output
  
  
asdfg asdfghjk
 

ac代码:

#include <iostream>
#include <string.h>
#include <cstdio>
const int N=100010;
int nextt[N];
using namespace std;
void get_next(char s[])
{
  int i=1,j=0;
  int len=strlen(s);
  nextt[0]=-1;
  while(i<len){
	  if(j==-1||s[i]==s[j]){
	    ++i;++j;nextt[i]=j;
	  }
	  else
		  j=nextt[j];
  }
}
int kmp(char ss[],char s[]){
  int len1=strlen(ss);
  int len2=strlen(s);
  get_next(s);
  int i=0,j=0;
  while(i<len1&&j<len2){
	  if(j==-1||ss[i]==s[j]){
	    ++i;++j;
	  }
	  else
		  j=nextt[j];
  }
  if(i==len1)
	  return j;
  else
	  return 0;
}
int main(){
	//freopen("1.txt","r",stdin);
  char str1[N],str2[N];
  while(scanf("%s%s",str1,str2)!=EOF){
    int x=kmp(str1,str2);
	int y=kmp(str2,str1);
	//printf("x==%d  y==%d\n",x,y);
	if(x==y){
		if(strcmp(str1,str2)>0){
		  printf("%s",str2);
		  printf("%s\n",str1+x);
		}
		else{
		  printf("%s",str1);
		  printf("%s\n",str2+x);
		}
	}
	else if(x>y){
	  printf("%s",str1);
	  printf("%s\n",str2+x);
	}
	else{
	  printf("%s",str2);
	  printf("%s\n",str1+y);
	}
  }
  return 0;
}


评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值