PAT1012. The Best Rank (25)

题目如下:

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output
1 C
1 M
1 E
1 A
3 A
N/A
题意大致是给出了每个学生的三门成绩,然后将每个学生的每门成绩给出相应的排名,输出每个学生的最好排名以及对应的学科。我想着是用一个结构体来保存每个学生的四门成绩以及四门排名,通过sort来排序并设置好每个学生每门成绩的排名,再在每个学生中找出最好的排名,代码如下:

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;

int index;
struct Student {
	string id;
	int grade[4];
	int rank[4];
};


bool compara(const Student& s1,const Student& s2)
{
	if (s1.grade[index] > s2.grade[index])
		return true;
	else
		return false;
}
void setRank(vector <Student>& v)
{
	for (index = 0;index < 4;index++)
	{
		sort(v.begin(), v.end(), compara);
		for (int i = 0;i < v.size();i++)
		{
			v[i].rank[index] = i + 1;
			for (int j = i + 1;j < v.size();j++) //处理成绩相等的情况
			{
				if (v[i].grade[index] == v[j].grade[index])
				{
					v[j].rank[index] = v[i].rank[index];
					i++;	//存在一个相等之后,后面的排名要往后+1
				}
				else
					break;
			}
		}
	}
	
}

int findBestRank(Student& s,string &bestCourse)
{
	int rank;
	if (s.rank[1] <= s.rank[2])
	{
		if (s.rank[0] <= s.rank[1])
		{
			if (s.rank[3]<= s.rank[0])
			{
				bestCourse = "A";
				rank = s.rank[3];
			}
			else
			{
				bestCourse = "C";
				rank = s.rank[0];
			}			
		}
		else
		{
			if (s.rank[3] <= s.rank[1])
			{
				bestCourse = "A";
				rank = s.rank[3];
			}
			else
			{
				bestCourse = "M";
				rank = s.rank[1];
			}			
		}
	}
	else
	{
		if (s.rank[0]<= s.rank[2])
		{
			if (s.rank[3] <= s.rank[0])
			{
				bestCourse = "A";
				rank = s.rank[3];
			}
			else
			{
				bestCourse = "C";
				rank = s.rank[0];
			}
				
		}
		else
		{
			if (s.rank[3] <= s.rank[2])
			{
				bestCourse = "A";
				rank = s.rank[3];
			}
			else
			{
				bestCourse = "E";
				rank = s.rank[2];
			}
				
		}
	}

	return rank;
}

int main()
{
	int N, M;
	vector <Student> students;
	Student temp;
	string id;
	string course;
	int rank;
	cin >> N >> M;
	//读入数据
	for (int i = 0;i < N;i++)
	{
		cin >> temp.id >> temp.grade[0] >> temp.grade[1] >> temp.grade[2];
		temp.grade[3] = (temp.grade[0] + temp.grade[1] + temp.grade[2]) / 3;
		students.push_back(temp);
	}
	//计算所有学科的排名
	setRank(students);

	for (int i = 0;i < M;i++)
	{
		cin >> id;
		int j;
		for (j = 0;j < N;j++)
		{
			if (students[j].id == id)
			{
				rank = findBestRank(students[j], course);
				cout << rank << " " << course << endl;
				break;
			}
		}
		if (j == N)
			cout << "N/A" << endl;
	}

	return 0;
}

要特别注意排名相同时,下一排名要往后移,比如1,1,3,4,5的排名,而不是1,1,2,3,4。我第一次提交时代码少处理了这一点,第二个用例点就会错误。经修改后上面的代码就通过了全部用例。这个题目还是蛮有意思的,让我把排序复习了下。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值