这道题目以前做过,其实就是一个nim游戏
Description
Here is a game for two players. The rule of the game is described below:
● In the beginning of the game, there are a lot of piles of beads.
● Players take turns to play. Each turn, player choose a pile i and remove some (at least one) beads from it. Then he could do nothing or split pile i into two piles with a beads and b beads.(a,b > 0 and a + b equals to the number of beads of pile i after removing)
● If after a player's turn, there is no beads left, the player is the winner.
Suppose that the two players are all very clever and they will use optimal game strategies. Your job is to tell whether the player who plays first can win the game.
● In the beginning of the game, there are a lot of piles of beads.
● Players take turns to play. Each turn, player choose a pile i and remove some (at least one) beads from it. Then he could do nothing or split pile i into two piles with a beads and b beads.(a,b > 0 and a + b equals to the number of beads of pile i after removing)
● If after a player's turn, there is no beads left, the player is the winner.
Suppose that the two players are all very clever and they will use optimal game strategies. Your job is to tell whether the player who plays first can win the game.
Input
There are multiple test cases. Please process till EOF.
For each test case, the first line contains a postive integer n(n < 10 5) means there are n piles of beads. The next line contains n postive integer, the i-th postive integer a i(a i < 2 31) means there are a i beads in the i-th pile.
For each test case, the first line contains a postive integer n(n < 10 5) means there are n piles of beads. The next line contains n postive integer, the i-th postive integer a i(a i < 2 31) means there are a i beads in the i-th pile.
Output
For each test case, if the first player can win the game, ouput "Win" and if he can't, ouput "Lose"
Sample Input
1 1 2 1 1 3 1 2 3
Sample Output
Win Lose Lose
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
int n,m;
while(~scanf("%d",&n))
{
int ans=0;
for(int i=1; i<=n; i++)
{
scanf("%d",&m);
ans^=m;
}
if(ans==0)
printf("Lose\n");
else
printf("Win\n");
}
return 0;
}
不知道为什么这样可以水过去,但是根据尼姆博弈,下面的才是正确的(区域赛的题目也水吗,还是我不懂啊,求解释)。。。----->>>尼姆博弈点击打开链接
#include<iostream>
#include<cstdio>
#include<string.h>
#include<algorithm>
#define N 1000001
using namespace std;
int main()
{
int n;
while(~scanf("%d",&n))
{
int s=0,ans=0;
for(int i=0; i<n; i++)
{
int a;
scanf("%d",&a);
if(a%2==1)
s++;
ans^=a;
}
//printf("********%d %d\n",s,ans);
if((ans==0&&s==0)||(ans!=0&&s>=1))
{
printf("Win\n");
}
if((ans!=0&&s==0)||(ans==0&&s>1))
printf("Lose\n");
}
return 0;
}