Oulipo 、Power Strings (KMP入门)

题目:

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0

参考代码:

#include<cstdio>
#include<cstring>
using namespace std;

int next[1000000];
char w[10000],t[1000000];

void getNext()
{
	int i = 0,j = -1;
	next[0] = -1;
	while(w[i])
	{
		if(j == -1 || w[i] == w[j])
		{
			++ i,++j;
			if(w[i] == w[j])
			next[i] = next[j];
			else next[i] = j;
		}
		else
		j = next[j];
	}
}

int find()
{
	int ans = 0;
	getNext();
	int i = 0,j = 0;
	while(t[i])
	{
		if(j == -1 || t[i] == w[j])
		++ i,++ j;
		else
		j = next[j];
		if(j != -1 && !w[j])
		{
			ans ++;
			j = next[j];
		}
	}
	return ans;
}

int main()
{
	int cases;
	scanf("%d",&cases);
	while(cases --)
	{
		scanf("%s",w);
		scanf("%s",t);
		printf("%d\n",find());
	}
}

http://blog.csdn.net/kakaxi2222/article/details/73826590

next数组当不匹配的时候返回的位置是:

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3

参考代码:

#include<cstdio>
#include<cstring>
char s[100000000];
int next[100000000];

int main()
{	
	while(scanf("%s",s),s[0]!='.')
	{
	
		int i,j,len = strlen(s);
		next[0] = next[1] = 0;
		for(i = 1;i < len;i ++)
		{
			j = next[i];
			while(j && s[i]!= s[j])
			j = next[j];
			next[i+1] = s[j]==s[i]?j+1:0;
		}
		if(len % (len-next[len]) == 0)
		printf("%d\n",len /(len - next[len]));
		else
		printf("1\n");
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值