Prime Gap(素数表+二分)

Description
The sequence of n − 1 consecutive composite numbers (positive integers that are not prime and not equal to 1) lying between two successive prime numbers p and p + n is called a prime gap of length n. For example, ‹24, 25, 26, 27, 28› between 23 and 29 is a prime gap of length 6.
Your mission is to write a program to calculate, for a given positive integer k, the length of the prime gap that contains k. For convenience, the length is considered 0 in case no prime gap contains k.
Input
The input is a sequence of lines each of which contains a single positive integer. Each positive integer is greater than 1 and less than or equal to the 100000th prime number, which is 1299709. The end of the input is indicated by a line containing a single zero.
Output
The output should be composed of lines each of which contains a single non-negative integer. It is the length of the prime gap that contains the corresponding positive integer in the input if it is a composite number, or 0 otherwise. No other characters should occur in the output.
Sample Input
10
11
27
2
492170
0
Sample Output
4
0
6
0

114

//首先打印素数表,然后用二分查找最接近m且大于m的素数在素数表中的下标,然后求区间长度(即该素数减去上一个素数的值);

#include<stdio.h>
#include<string.h>
#define Max 1299709+4
#define Len 100004
int prime[Len],tot;
int vis[Max];
struct node
{
	int left,right,gap;
}tree[4*Len];
void make_prime()
{
	memset(vis,0,sizeof(vis));
	tot=1;
	int i,j;
	for(i=2;i<Max;i++)
	{
		if(!vis[i])
		{
			prime[tot++]=i;
			for(j=i+i;j<Max;j+=i)
				vis[j]=1;
		}
	}
}
int find(int low,int high,int m)
{
	int mid;
	while(low<=high)
	{
		mid=(low+high)/2;
		if(m<=prime[mid])
			high=mid-1;
		else low=mid+1;
	}
	return low;
}
int main()
{
	//freopen("b.txt","r",stdin);
	int m;
	make_prime();
	while(scanf("%d",&m)==1,m)
	{
		int tmp=find(1,tot-1,m);
		if(prime[tmp]==m) puts("0");
		else
		printf("%d\n",prime[tmp]-prime[tmp-1]);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值