Prime Gap (二分法)

Prime Gap

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 14   Accepted Submission(s) : 13
Problem Description

The sequence of n 1 consecutive composite numbers (positive integers that are not prime and not equal to 1) lying between two successive prime numbers p and p + n is called a prime gap of length n. For example, 24, 25, 26, 27, 28 between 23 and 29 is a prime gap of length 6.

Your mission is to write a program to calculate, for a given positive integer k, the length of the prime gap that contains k. For convenience, the length is considered 0 in case no prime gap contains k.

 

Input
<p>The input is a sequence of lines each of which contains a single positive integer. Each positive integer is greater than 1 and less than or equal to the 100000th prime number, which is 1299709. The end of the input is indicated by a line containing a single zero.</p>
 

Output
<p>The output should be composed of lines each of which contains a single non-negative integer. It is the length of the prime gap that contains the corresponding positive integer in the input if it is a composite number, or 0 otherwise. No other characters should occur in the output.</p>
 

Sample Input
  
  
10 11 27 2 492170 0
 

Sample Output
  
  
4 0 6 0 114
 

Source
PKU
 

题意:

给你一个数,如果这个数是素数则直接输出0,否则寻找到他所在的素数区间(即后一个素数减去前一个)。

思路:

开两个数组,一个用来存放素数(此处寻找素数我们使用筛素数的方法),一个来判断是不是素数。然后再从素数结果里前一个大于他的后一个小于他的,输出他们的差即可。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#include <iomanip>
#define maxn  1299809
#define mod 1000000007
#define inf 0x3f3f3f3f
#define exp 1e-6
#define pi acos(-1.0)
using namespace std;
int s[100005];
bool a[maxn];
int main()
{
    int i,j,num=0;
    int k;
    memset(a,1,sizeof(a));
    a[0]=a[1]=0;
    for(i=2;i<maxn;i++)
    {
        if(a[i])
        {
            for(j=2*i;j<maxn;j+=i)
            a[j]=0;
            s[++num]=i;
        }
    }
    while(cin>>k,k)
    {
        if(a[k]==1) { cout<<'0'<<endl; continue;}

        int left=1,right=num,mid;
        while(left<num)
        {
            mid=(left+right)/2;
            //if(a[mid]==n) {printf("0\n"); break;}
            if(s[mid]<k&&s[mid+1]>k) {cout<<s[mid+1]-s[mid]<<endl; break;}
            if(s[mid]>k) right=mid-1;
            else left=mid+1;
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值