HIT 1014 高精度水题

 

Niven Numbers

 Source : Unknown
 Time limit : 1 sec Memory limit : 32 M

Submitted : 4166, Accepted : 681

A Niven number is a number such that the sum of its digits divides itself. For example, 111 is a Niven number because the sum of its digits is 3, which divides 111. We can also specify a number in another base b, and a number in base b is a Niven number if the sum of its digits divides its value.

Given b (2 <= b <= 10) and a number in base b, determine whether it is a Niven number or not.


Input

Each line of input contains the base b, followed by a string of digits representing a positive integer in that base. There are no leading zeroes. The input is terminated by a line consisting of 0 alone.


Output

For each case, print "yes" on a line if the given number is a Niven number, and "no" otherwise.


Sample Input

10 111
2 110
10 123
6 1000
8 2314
0

Sample Output

yes
yes
no
yes
no

 
题目很简单,可以直接用高精度水过。
我用的java,毫无压力呀~
 
我的代码:
import java.util.*;
import java.math.*;

public class Main {
	public static void main(String args[])
	{
		Scanner cin=new Scanner(System.in);
		BigInteger a,c,d;
		int b,i,l;
		String str1,str2; 
		while(true)
		{
			b=cin.nextInt();
			if(b==0)
				break;
			str1=cin.next();
			l=str1.length();
			a=BigInteger.ZERO;
			c=BigInteger.ZERO;
			for(i=0;i<l;i++)
			{
				a=a.multiply(BigInteger.valueOf(b)).add(BigInteger.valueOf(str1.charAt(i)-'0'));
				c=c.add(BigInteger.valueOf(str1.charAt(i)-'0'));
			}
			d=a.mod(c);
			if(d.compareTo(BigInteger.ZERO)==0)
				System.out.println("yes");
			else
				System.out.println("no");
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值