Niven Numbers 进制转换

Niven Numbers

Time Limit: 2 Seconds       Memory Limit: 65536 KB

A Niven number is a number such that the sum of its digits divides itself. For example, 111 is a Niven number because the sum of its digits is 3, which divides 111. We can also specify a number in another base b, and a number in base b is a Niven number if the sum of its digits divides its value.

Given b (2 <= b <= 10) and a number in base b, determine whether it is a Niven number or not.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


Input

You will be given a number of test cases. Each line of input contains the base b, followed by a string of digits representing a positive integer in that base. There are no leading zeroes. The input is terminated by a line consisting of 0 alone.


Output

For each case, print "yes" on a line if the given number is a Niven number, and "no" otherwise.


Sample Input

1

10 111
2 110
10 123
6 1000
8 2314
0


Sample Output

yes
yes
no
yes
no


#include <iostream>   
#include <string> 
#include<cmath>
using namespace std;   
int main(){   
    int base,n;   
    string num; 
	cin>>n;
    while (n--)
	{  
        while(cin>>base&&base) 
		{
        
			 cin>>num;
			 int x=0,y=0;   
			 for (int i=0;i<num.length();++i)
			 {   
				 x+=num[i]-'0';   
				 y+=(num[i]-'0')*pow(base,num.length()-1-i);   
			
			 }
		
		    if(y%x==0)
				cout<<"yes"<<endl;
			else
				cout<<"no"<<endl;
		}
	if(n)
		cout<<endl;
		
    }   
    return 0;   
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值