HOJ 1014 Niven Numbers

Niven Numbers

My Tags  (Edit)
  Source : Unknown
  Time limit : 1 sec   Memory limit : 32 M

Submitted : 5290, Accepted : 935

A Niven number is a number such that the sum of its digits divides itself. For example, 111 is a Niven number because the sum of its digits is 3, which divides 111. We can also specify a number in another base b, and a number in base b is a Niven number if the sum of its digits divides its value.

Given b (2 <= b <= 10) and a number in base b, determine whether it is a Niven number or not.


Input

Each line of input contains the base b, followed by a string of digits representing a positive integer in that base. There are no leading zeroes. The input is terminated by a line consisting of 0 alone.


Output

For each case, print "yes" on a line if the given number is a Niven number, and "no" otherwise.


Sample Input

10 111
2 110
10 123
6 1000
8 2314
0

Sample Output

yes
yes
no
yes
no



比较水的一个题

本来刷数学类的从上到下应该是1013的结果太难了竟然不会2333只好挑个简单的做了

大概意思就是给你一个进制和该进制下的数m

问m能否整除 m每个位上的数的和

并没有什么难度

然而并没有告诉你m的大小所以用字符串存吧

而且在转化成10进制算余数时

也要边乘边加边取余

否则也会爆掉 I guess


贴代码睡觉去

/*This Code is Submitted by abgnwl for Problem 1014 at 2015-05-18 23:26:04*/
#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
int base;
string str;
int tot;
int main()
{
    while(scanf("%d",&base)==1)
    {
        if(base==0)break;
        cin>>str;
        int len=str.length();
        tot=0;
        for(int i=0;i<len;++i)
            tot=tot+str[i]-'0';
        int now=1,m=0;
        for(int i=0;i<len;++i)
        {
            m=(m+(str[len-i-1]-'0')*now)%tot;
            now=(now*base)%tot;
        }
        if(m%tot==0)
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值