poj1226之kmp入门

Substrings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10370 Accepted: 3565

Description

You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.

Output

There should be one line per test case containing the length of the largest string found.

Sample Input

2
3
ABCD
BCDFF
BRCD
2
rose
orchid

Sample Output

2
2 

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=100+10;
char s[MAX][MAX],temp1[MAX],temp2[MAX];
int next[MAX];

void Strcpy(char *a,char *b,int S,int T){
	int k=0;
	for(int i=S;i<=T;++i){
		a[k++]=b[i];
	}
	a[k]='\0';
}

void get_next(char *a){
	int i=0,j=-1;
	next[0]=-1;
	while(i<strlen(a)){
		if(j == -1 || a[i] == a[j]){
			if(a[++i] != a[++j])next[i]=j;
			else next[i]=next[j];
		}else j=next[j];
	}
	return;
}

bool KMP(char *a,char *b){
	int i=0,j=0,lena=strlen(a),lenb=strlen(b);
	if(lena>lenb)return false;
	get_next(a);
	while(i<lena && j<lenb){
		if(i == -1 || a[i] == b[j])++i,++j;
		else i=next[i];
	}
	if(i>=lena)return true;
	return false;
}

int main(){
	int t,n,k;
	cin>>t;
	while(t--){
		cin>>n;
		for(int i=0;i<n;++i)cin>>s[i];
		int len=strlen(s[0]),maxlen=0;
		for(int i=0;i<len;++i){
			for(int j=i;j<len;++j){
				Strcpy(temp1,s[0],i,j);
				int L=strlen(temp1);
				for(k=0;k<L;++k)temp2[k]=temp1[L-1-k];
				temp2[L]='\0';
				for(k=1;k<n;++k){
					if(!KMP(temp1,s[k]) && !KMP(temp2,s[k]))break;
				}
				if(k == n)maxlen=max(maxlen,j-i+1);
			}
		}
		cout<<maxlen<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值