hihocoder1082 然而沼跃鱼早就看穿了一切

时间限制: 1000ms
单点时限: 1000ms
内存限制: 256MB

描述


fjxmlhx每天都在被沼跃鱼刷屏,因此他急切的找到了你希望你写一个程序屏蔽所有句子中的沼跃鱼(“marshtomp”,不区分大小写)。为了使句子不缺少成分,统一换成 “fjxmlhx” 。

输入

输入包括多行。

每行是一个字符串,长度不超过200。

一行的末尾与下一行的开头没有关系。

输出

输出包含多行,为输入按照描述中变换的结果。

样例输入
The Marshtomp has seen it all before.
marshTomp is beaten by fjxmlhx!
AmarshtompB
样例输出
The fjxmlhx has seen it all before.
fjxmlhx is beaten by fjxmlhx!

AfjxmlhxB

//比较笨的方法,水题不用想太多

#include "iostream"
#include "cstdio"
#include "cstring"
using namespace std;

bool f(int i,char s[]){

    if((s[i]=='m'||s[i] == 'M')&&(s[i+1]=='a'||s[i+1]=='A')
        &&(s[i+2]=='r'||s[i+2]=='R')&&(s[i+3]=='s'||s[i+3]=='S')
         &&(s[i+4]=='h'||s[i+4]=='H')&&(s[i+5]=='t'||s[i+5]=='T')
          &&(s[i+6]=='o'||s[i+6]=='O')&&(s[i+7]=='m'||s[i+7]=='M')&&(s[i+8]=='p'||s[i+8]=='P')) return 1;
    return 0;
}
int main(){
    char s[205],ch[205],t[] = "fjxmlhx";
    while(gets(s) && s != '\0') {

                int k,flag = 0;
                int j = 0;
            for(int i = 0; i < strlen(s); i++) {
                    if(f(i,s)) {{
                       cout << t;
                       i= i + 8;
                    }
                    }
                    else cout << s[i];
            }
        cout << endl;
}
 return 0 ;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值