HDU3711 Binary Number

最近一段时间杭电10点就打烊了!题目链接就不上了;

很长一段时间没有更新博客了!最近一段时间会陆陆续续的将近期做过的一些题目分享出来,也是为了勉励自己!

Description

For 2 non-negative integers x and y, f(x, y) is defined as the number of different bits in the binary format of x and y. For example, f(2, 3)=1,f(0, 3)=2, f(5, 10)=4. Now given 2 sets of non-negative integers A and B, for each integer b in B, you should find an integer a in A such that f(a, b) is minimized. If there are more than one such integer in set A, choose the smallest one.

Input

The first line of the input is an integer T (0 < T ≤ 100), indicating the number of test cases. The first line of each test case contains 2 positive integers m and n (0 < m, n ≤ 100), indicating the numbers of integers of the 2 sets A and B, respectively. Then follow (m + n) lines, each of which contains a non-negative integers no larger than 1000000. The first m lines are the integers in set A and the other n lines are the integers in set B.

Output

For each test case you should output n lines, each of which contains the result for each query in a single line.

Sample Input

2
2 5
1
2
1
2
3
4
5
5 2
1000000
9999
1423
3421
0
13245
353

Sample Output

1
2
1
1
1
9999
0

题目大意:

就是给我们两个集合A和B要我们用A中的每个元素去匹配B中的每个元素,得到其中元素二进制不同的数的个数最小的那个!

举个栗子就懂了:比如第一组数据集合A为的元素为(1,2),B的元素为(1,2,3,4,5)

将其中元素转换成而二进制数看看 :

1   -> 0001

2   -> 0010

3   -> 0011

4   -> 0100

5   -> 0101

那么我们可以看书,(Ai,B1)(i=0,1....代表A集合数组的下边)中(1,1)二进制位不同的个数为 0;(2,1)中二进制位不同的个数为 1;那么个数最小的就是匹配到A1的时候,所以第一个样例的输出结果就是 1:;

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
//const int mINF=0XFFFFFFFF;
int a[1005],b[1005];
int fc(int x,int y)
{
	int count=0;
	while(1)
	{
		if((x&1)!=(y&1))count++;
		x=x>>1;
		y=y>>1;
		if(x==0&&y==0)return count;
	}
}
long long fmint,post;
int main()
{
//	cout<<(1&1)<<endl;
//	cout<<(1&0)<<endl;
//	cout<<(0&0)<<endl;
	int T;
	cin>>T;
	while(T--)
	{
		int n,m;
		cin>>m>>n;
		for(int i=0;i<m;i++)cin>>a[i];
		for(int i=0;i<n;i++)cin>>b[i];
		sort(a,a+m);
		for(int i=0;i<n;i++)
		{
			fmint=0xfffffff,post=-1;
			int t;
			for(int j=0;j<m;j++)
			{
				t=fc(b[i],a[j]);
				if(fmint>t)fmint=t,post=j;
			}
			cout<<a[post]<<endl;
		}
		
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值