Description
To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.
(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).
Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.
(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).
Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.
Input
* Line 1: A single integer, N
* Lines 2..N+1: The serial numbers to be tested, one per line
* Lines 2..N+1: The serial numbers to be tested, one per line
Output
* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.
Sample Input
4 36 38 40 42
Sample Output
38
题目大意:就是求所给数的素因子最大的数,如果存在多个这样的数,那么输出他们中最小的就可以了:
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
const int M=200005;
int prime[M],pe[M];
void Init()
{
memset(prime,0,sizeof(prime));
for(int i=2;i<M;i++)
{
if(!prime[i])
{
for(int j=i+i;j<M;j+=i)
{
prime[j]=1;
}
}
}
int j=0;
for(int i=2;i<M;i++)
{
if(!prime[i])
// cout<<i<<" ";
pe[j++]=i;
}
}
int solve(int a)
{
int t=0;
for(int i=0;pe[i]<=a;i++)
{
if(a%pe[i]==0)t=pe[i];
}
return t;
}
int main()
{
Init();
int N,a;
while(cin>>N)
{
int pmax=-1;
int res;
for(int i=0;i<N;i++)
{
cin>>a;
int temp=solve(a);
// cout<<"temp="<<temp<<endl;
if(pmax<temp)
{
res=a;
pmax=temp;
}
}
cout<<res<<endl;
}
return 0;
}