poj3617_简单贪心

Best Cow Line
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18790 Accepted: 5228

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

<span style="font-size:14px;">#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <stack>
#include <queue>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <vector>
#include <bitset>
#include <list>
#include <sstream>
#include <set>
#include <functional>
using namespace std;

#define INT_MAX 1 << 30
#define MAX 100
typedef long long ll;
int n;
char s[300];

void solve()
{
    int a = 0;
    int b = n-1;
    int num = 0;
    while (a<=b)
    {
        bool left = true;
        for (int i = 0; a+i < b-i; i += 1)
        {
            if(s[a+i] < s[b-i])
            {
                num++;
                break;   
            }
            else if(s[a+i] > s[b-i])
            {
                left = false;
                num++;
                break;
            }
        }
        if (left)
        {
            putchar(s[a++]);
        }
        else
        {
            putchar(s[b--]);
        }
        if(num%80 == 0)
            putchar('\n');
    }
    if(num%80)
        putchar('\n');
}

int main(int argc, char const* argv[])
{
    scanf("%d",&n);
    getchar();
    for (int i = 0; i < n; i += 1)
    {
        scanf("%c",&s[i]);
        getchar();
    }
    solve();
    return 0;
}</span>
分析:

将字符组成一个字符串,每次拿前半部分的第一个和后半部分的第一个比较,由外及内,每次取较小的那个。

也可以理解成将一个字符串和它的镜面字符串比较,但只需比较一般长度即可。

最后别忘了80个字符串一行。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值