#训练题,贪心排字母

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows’ names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he’s finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

  • Line 1: A single integer: N
  • Lines 2…N+1: Line i+1 contains a single initial (‘A’…‘Z’) of the cow in the ith position in the original line

Output
The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows (‘A’…‘Z’) in the new line.

Sample Input
6
A
C
D
B
C
B
Sample Output
ABCBCD
理解题意以后,可以明白,其实就是先给你一串字母T,每次可以从这一串字母里取第一位或者最后一位,重新组成一串字母(按取的顺序排列),要求重新组成的字母串是最小的。例如ACDBCB,首先,我们从A,B中取一个,因为要求最小,所以我们每次都取最小的,所以第一位是A,然后T就变成了CDBCB,再从C,B中取一个排在A后面,所以取B后,新字母串就是AB,T变成了CDBC,当遇到相同字母时,我们比较它们的下一位,找出下一位更小的(D,B中B小,所以取最后一位的C),如此反复取字母排出的就是正确答案。(这一题中要求每80个字母后需要换行)。
下面是代码:
#include<stdio.h>
int main()
{
int n;
while(~scanf("%d",&n))
{
int i,j,k,l;
char a[5000];
for(i=0;i<n;i++)
{
getchar();
scanf("%c",&a[i]);
}
j=0;
k=n-1;
int sum=0;
while(j<=k)
{
l=0;
for(i=0;i+j<=k;i++)
{
if(a[j+i]<a[k-i])
{
l=1;
break;
}
if(a[j+i]>a[k-i])
{
l=0;
break;
}
//这里虽然没有另外讨论a[j+i]a[k-i],但是当两项相等时,循环继续运行,J和K的值并不改变,i改变,直接将下一项进行比较,只有比较出两项的大小后才会跳出循环 ,然后输出的还是A[J]或a[k]
}
if(l
1)
{
printf("%c",a[j]);
j++;
}
if(l0)
{
printf("%c",a[k]);
k–;
}
sum++;
if(sum
80)
{
printf("\n");
sum=0;
}
}
printf("\n");
}
return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值