ZOJ - 3469 Food Delivery (区间dp)

传送门

When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.

Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person's coordinate is Xi meters. And in the street there is a take-out restaurant which has coordinates X meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food to the N people, and then come back to the restaurant. Your speed is V-1 meters per minute.

You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure Index. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ith person will gain Bi Displeasure Index per minute.

If one's Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people's Displeasure Index as low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index.

Input

The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0), X ( X >= 0 ), then Nlines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi >= 0), which are described above.

You can safely assume that all numbers in the input and output will be less than 231- 1.

Please process to the end-of-file.

Output

For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.

Sample Input

5 1 0
1 1
2 2
3 3
4 4
5 5


Sample Output

55

题意: 在x轴上有n个客人同时叫外卖,每个顾客在等外买的时间里每秒增加的愤怒值不同。给出客人和餐厅的位置,以及客人每分钟增加的愤怒值,还有快递小哥的行走一公里需要的时间。问送完外卖后n个客人的最小愤怒值?

其实一开始真的完全懵逼,还以为会是一个贪心题==,然后感觉贪不出来,又开在了dp专题里面,不免就想到了自己每次写的毫无理由的区间dp,接下来就是找动态转移方程了。先把外卖小哥所在的点加进去,然后根据所在地点从小到大的排序,然后外卖小哥所在的地点开始向左向右扫描

dp[i][j][0]表示送完i到j的外卖客户的最小不开心值,此时停在i点;dp[i][j][1]表示送完i到j的外卖客户的最小不开心值,此时停在j点;动态转移方程有四个:

dp[i][j][0] = min(dp[i][j][0] , dp[i+1][j][0] + (no[i+1].x - no[i].x) *(sum[n]-sum[j]+sum[i]));

dp[i][j][0] = min(dp[i][j][0] , dp[i+1][j][1] + (no[j].x - no[i].x) *(sum[n]-sum[j]+sum[i]));

dp[i][j][1] = min(dp[i][j][1] , dp[i][j-1][1] + (no[j].x - no[j-1].x) *(sum[n]-sum[j-1]+sum[i-1]));

dp[i][j][1] = min(dp[i][j][1] , dp[i][j-1][0] + (no[j].x - no[i].x) *(sum[n]-sum[j-1]+sum[i-1]));


#include<stdio.h>
#include<iostream>
#include<set>
#include<queue>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<string>
#include<vector>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
struct node{
    int x , b ;
}no[1005];
int dp[1005][1005][2];
bool cmp(node x , node y){
    return x.x < y.x;
}
int sum[1005];
int n , v , x;
int main()
{
    while(~scanf("%d%d%d" , &n , &v , &x)){
        for(int i = 1 ; i <= n ; i ++)
            scanf("%d%d" , &no[i].x , &no[i].b);
        no[++n].x = x ;  no[n].b = 0 ;
        sort(no + 1 , no + n + 1 , cmp);
        sum[0] = 0 ;
        for(int i = 1 ; i <= n ; i ++){
            sum[i] = sum[i - 1] + no[i].b;
        }
        for(int i = 0 ; i <= n ; i ++){
            for(int j = 0 ; j <= n ; j ++){
                dp[i][j][0] = dp[i][j][1] = inf;
            }
        }
        int mid = 0;
        for(int i = 1 ; i <= n ; i ++){
            if(no[i].x == x){
                mid = i ;
                dp[i][i][0] = dp[i][i][1] = 0;
                break;
            }
        }//初始化起点,即送餐开始位置
        for(int i = mid ; i > 0 ; i --){//分别向左向右dp
            for(int j = mid ; j <= n ; j ++){
                if(i == j)
                    continue;
                dp[i][j][0] = min(dp[i][j][0] , dp[i+1][j][0] + (no[i+1].x - no[i].x) *(sum[n]-sum[j]+sum[i]));
                dp[i][j][0] = min(dp[i][j][0] , dp[i+1][j][1] + (no[j].x - no[i].x) *(sum[n]-sum[j]+sum[i]));
                dp[i][j][1] = min(dp[i][j][1] , dp[i][j-1][1] + (no[j].x - no[j-1].x) *(sum[n]-sum[j-1]+sum[i-1]));
                dp[i][j][1] = min(dp[i][j][1] , dp[i][j-1][0] + (no[j].x - no[i].x) *(sum[n]-sum[j-1]+sum[i-1]));
            }
        }
        cout<<(min(dp[1][n][1] , dp[1][n][0]))*v<<endl;//最后可以停在最左边或者最右边
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值