HDU - 3709 : Balanced Number (数位dp)

题目链接 : HDU-3709

A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job 
to calculate the number of balanced numbers in a given range [x, y].
Input
The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10  18).
Output
For each case, print the number of balanced numbers in the range [x, y] in a line.
Sample Input
2
0 9
7604 24324
Sample Output
10
897
题意:计算从l到r有多少个平衡数。即从该数的某一位分开,两边的权值相等。

题解:记录的时候注意记录两边的权值差值~不然数组会炸掉~


#include<stdio.h>
#include<iostream>
#include<set>
#include<math.h>
#include<algorithm>
#include<string.h>
#include<string>
#include<queue>
#include<vector>
using namespace std;
#define ll long long
const int inf = 0x3f3f3f3f;

ll dp[20][20][3600];
int digt[20];
ll dfs(int pos , int mid , int sub , bool limit) {
    if(pos < 0)
        return sub == 0;
    if(!limit && dp[pos][mid][sub] != -1)
        return dp[pos][mid][sub];
    int prepos = limit ? digt[pos] : 9;
    ll ans =0 ;
    for(int i = 0 ; i <= prepos ; i ++) {
        ans += dfs(pos - 1 , mid , sub + (pos - mid)*i , limit&&i == prepos);
    }
    if(!limit)
        dp[pos][mid][sub] = ans;
    return ans;
}
ll solve(ll x) {
    memset(digt , 0 , sizeof(digt));
    int k = 0 ;
    while(x) {
        digt[k++] = x % 10;
        x /= 10;
    }
    ll ans = 0 ;
    for(int i = 0 ; i < k ; i ++) {
        ans += dfs(k - 1 , i , 0 , 1);
    }
    return ans - k;
}
int main()
{
    //freopen("in.txt" , "r", stdin);
    ll l , r ;
    int t ;
    memset(dp , -1 , sizeof(dp));
    scanf("%d" , &t);
    while(t--) {
        scanf("%lld %lld" , &l , &r) ;
        printf("%lld\n" , solve(r) - solve(l - 1));
    }
    return 0;
}









  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值