POJ - 3252 : Round Numbers (数位dp)

题目链接 : POJ-3252

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input
Line 1: Two space-separated integers, respectively  Start and  Finish.
Output
Line 1: A single integer that is the count of round numbers in the inclusive range Start..  Finish
Sample Input
2 12
Sample Output
6
题意:求l到r范围内有多少个round number。

round number:将十进制转换成二进制后,0的个数大于等于1的个数


题解:太久没刷题,快要变成dp只会找规律了,一开始没想到直接按二进制计算,按照十进制找了好久的规律。。。真的是越来越蠢~

其实想到二进制去做之后就是一个纯数位dp的模板题了


#include<stdio.h>
#include<iostream>
#include<set>
#include<math.h>
#include<algorithm>
#include<string.h>
#include<string>
#include<queue>
#include<vector>
using namespace std;
#define ll long long
const int inf = 0x3f3f3f3f;

ll dp[50][50][50];
int digt[50];
ll dfs(int pos , int num0 , int num1 , int flag , bool limit) {
    if(pos < 0)
        return num1 <= num0 ;
    if(!limit && dp[pos][num0][num1] != -1)
        return dp[pos][num0][num1];
    int prepos = limit ? digt[pos] : 1 ;
    ll ans = 0 ;
    for(int i = 0 ; i <= prepos ; i ++) {
        if(!flag) {
            if(i) ans += dfs(pos - 1 , num0 , num1 + 1 , flag && !i , limit && i == prepos) ;
            else  ans += dfs(pos - 1 , num0 + 1 , num1 , flag && !i , limit && i == prepos) ;
        }
        else {
            if(i) ans += dfs(pos - 1 , num0 , num1 + 1 , flag && !i , limit && i == prepos) ;
            else  ans += dfs(pos - 1 , num0 , num1     , flag && !i , limit && i == prepos) ;
        }
    }
    if(!limit)
        dp[pos][num0][num1] = ans;
    return ans ;
}

ll solve(ll x) {
    memset(digt , 0 , sizeof(digt));
    int k = 0 ;
    while(x) {
        digt[k++] = x % 2;
        x /= 2;
    }
    return dfs(k-1 , 0 , 0 , 1 , 1);
}
int main() {
    memset(dp , -1 , sizeof(dp));
    ll l , r;
    while(~scanf("%lld %lld" , &l , &r)) {
        printf("%lld\n" , solve(r) - solve(l-1));
    }
    return 0 ;
}








  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值