hdu2955 Robberies(01背包)题解

传送门

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university. 


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible. 


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set. 

Notes and Constraints 
0 < T <= 100 
0.0 <= P <= 1.0 
0 < N <= 100 
0 < Mj <= 100 
0.0 <= Pj <= 1.0 
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
Sample Output
2
4
6
题意:给定一个固定概率p,要求在总风险小于p的情况下所获得的价值最大。

其实就是一个简单的01背包,但是要稍微的转换一下。一定要注意这里的概率的精度并不是0.01,刚开始就错误的理解为0.01然后wa了一发,真的好菜啊。。。

在这里,dp[i]保存的是获得的价值为i时的最大安全概率,1-风险概率=安全概率,当抢 劫为0时,安全概率为1,所以dp[0] =1,其他的初始化为0,分析可得状态转移方程为:

dp[j] = max(dp[j] , dp[j - no[i].mi] * no[i].pi);

注意:后面的概率要相乘

#include<stdio.h>
#include<iostream>
#include<set>
#include<queue>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<string>
#include<vector>
using namespace std;
typedef long long ll;
double dp[100000];
struct node{
    int mi ;
    double pi;
}no[105];
int main()
{
    int t , n;
    double p;
    scanf("%d" , &t);
    while(t--){
        scanf("%lf %d" , &p , &n);
        p = 1 - p ;
        int sum = 0;
        for(int i = 1 ; i <= n ; i ++){
            scanf("%d %lf" , &no[i].mi , &no[i].pi);
            no[i].pi = 1 - no[i].pi;
            sum += no[i].mi;
        }
        memset(dp , 0 , sizeof(dp));
        dp[0] = 1;
        for(int i = 1 ; i <= n ; i ++){
            for(int j = sum ; j >= no[i].mi ; j --){
                dp[j] = max(dp[j] , dp[j - no[i].mi] * no[i].pi);
            }
        }
        for(int i = sum ; i >= 0 ; i --){
            if(dp[i] >= p){
                cout<<i<<endl;
                break;
            }
        }
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值