HDOJ--1171Big Event in HDU!母函数

原文链接

Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
  
  
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
  
  
20 10 40 40
 

题目大意:给你一些机器,每种机器有每种机器不同的价值,每次输入机器价值(V<=50),每种机器数量(M<=100),输入时候可能有相同的机器和数量

请计算是否可以平分有相同价值的机器,(机器明显不可以拆分),如果不可以,请按照价值从大到小输入。

思路:母函数


代码:

#include<stdio.h>
#include<string.h>

#define max 260000
#define valuemax 50

int c1[max];
int c2[max];
int value[valuemax+1];

int main()
{
	int i,j,k,t_arr,t_num,N,max_num,ans1,ans2,t;
	while(scanf("%d",&N)&&N>=0)
	{
		memset(c1,0,sizeof(c1));
		memset(c2,0,sizeof(c2));
		memset(value,0,sizeof(value));
		max_num=0;
		c1[0]=1;
		for(i=0;i<N;i++)     //输入到数组数据 
		{
			scanf("%d",&t_arr);
			scanf("%d",&t_num);
			value[t_arr]+=t_num;
			max_num+=t_arr*t_num;
		}
		for(i=1;i<=valuemax;i++)    //母函数 
		{
			for(j=0;j<=value[i];j++)
			{
				for(k=0;k+j*i<=max_num;k++)
				{
					c2[k+j*i]+=c1[k];
				}
			}
			for(j=0;j<=max_num;j++)
			{
				c1[j]=c2[j];
				c2[j]=0;
			}
		}
		for(i=max_num/2;i<=max;i++)   //找相近的两个数,先找大数 
		{
			if(c1[i])
			{
				ans1=i;
				break;
			}
		}
		ans2=max_num-ans1;   //另一个数字是总数减去ans1 
		if(ans1<ans2)        //比较大小 
		{
			t=ans1;
			ans1=ans2;
			ans2=t;
		}
		printf("%d %d\n",ans1,ans2);
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值