poj Game Prediction 1323 (贪心ordp)

51 篇文章 0 订阅
27 篇文章 0 订阅
Game Prediction
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10194 Accepted: 4892

Description

Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game.



Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game.

Input

The input consists of several test cases. The first line of each case contains two integers m (2?20) and n (1?50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases.

The input is terminated by a line with two zeros.

Output

For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game.

Sample Input

2 5
1 7 2 10 9

6 11
62 63 54 66 65 61 57 56 50 53 48

0 0

Sample Output

Case 1: 2
Case 2: 4
//题意:
有m个人,每人有n张牌,(Hait: 暗示有n*m张牌)轮流出牌,谁出的牌最大,谁赢,问你至少能赢几场。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[1010];
int b[1010];
int cmp(int a,int b)
{
	return a>b;
}
int main()
{
	int T=1,n,m,i,j;
	while(scanf("%d%d",&m,&n),n|m)
	{
		memset(b,0,sizeof(b));
		int k=n;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			b[a[i]]=1;
		}
		sort(a+1,a+n+1);
		int mm=n*m;
		int l=0,w=0;
		while(1)
		{
			if(mm==a[k])
				w++;
			else
			{
				l++;
				mm--;
			}
			if(l+w==n)
				break;
			k--;
			mm--;
		}
		printf("Case %d: %d\n",T++,w);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值