CodeForces - 141B Hopscotch (模拟)水

CodeForces - 141B
Time Limit:                                                        2000MS                        Memory Limit:                                                        262144KB                        64bit IO Format:                            %I64d & %I64u                       

Status

Description

So nearly half of the winter is over and Maria is dreaming about summer. She's fed up with skates and sleds, she was dreaming about Hopscotch all night long. It's a very popular children's game. The game field, the court, looks as is shown in the figure (all blocks are square and are numbered from bottom to top, blocks in the same row are numbered from left to right). Let us describe the hopscotch with numbers that denote the number of squares in the row, staring from the lowest one: 1-1-2-1-2-1-2-(1-2)..., where then the period is repeated (1-2).

The coordinate system is defined as shown in the figure. Side of all the squares are equal and have length a.

Maria is a very smart and clever girl, and she is concerned with quite serious issues: if she throws a stone into a point with coordinates (x, y), then will she hit some square? If the answer is positive, you are also required to determine the number of the square.

It is believed that the stone has fallen into the square if it is located strictly inside it. In other words a stone that has fallen on the square border is not considered a to hit a square.

Input

The only input line contains three integers: a, x, y, where a (1 ≤ a ≤ 100) is the side of the square, x and y ( - 106 ≤ x ≤ 106, 0 ≤ y ≤ 106) are coordinates of the stone.

Output

Print the number of the square, inside which the stone fell. If the stone is on a border of some stone or outside the court, print "-1" without the quotes.

Sample Input

Input
1 0 0
Output
-1
Input
3 1 1
Output
1
Input
3 0 10
Output
5
Input
3 0 7
Output
-1
Input
3 4 0
Output
-1

Sample Output

Hint

Source

//题意:
给你一个积木堆,积木的样式是第一层只有一个正方体,然后上面就开始循环了,循环体为(第一层是一个正方体,第二层是两个正方体)。
现在给你三个数a,x,y表示正方体的边长,然后让你输出坐标(x,y),对应的数是什么?如果在积木的边界上或者是不在正方体上输出-1。
//思路:
先根据y算出所在的层数,根据层数找到这层对应的数,然后根据x判断是否在正方体上。
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<iostream>
using namespace std;
int main()
{
	int a,y;
	double x;
	int n,m;
	while(scanf("%d%lf%d",&a,&x,&y)!=EOF)
	{
		if(y%a==0)
			printf("-1\n");
		else
		{
			int k=y/a;
			int kk=k/2;
			if(k==0)
			{
				if(a*0.5-fabs(x)>1e-3)
					printf("1\n");
				else
					printf("-1\n");
			}
			else if(k&1)
			{
				m=1+kk*3+1;
				if(a*0.5-fabs(x)>1e-3)
					printf("%d\n",m);
				else
					printf("-1\n");
			}
			else
			{
				m=1+kk*3;
				if(x<0&&a*1.0-fabs(x)>1e-3)
					printf("%d\n",m-1);
				else if(x>0&&a*1.0-fabs(x)>1e-3)
					printf("%d\n",m);
				else
					printf("-1\n");
			}
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值