POJ 2353 Ministry(双向动规 输出过程)

Ministry
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 5020
Accepted: 1622
Special Judge

Description

Mr. F. wants to get a document be signed by a minister. A minister signs a document only if it is approved by his ministry. The ministry is an M-floor building with floors numbered from 1 to M, 1<=M<=100. Each floor has N rooms (1<=N<=500) also numbered from 1 to N. In each room there is one (and only one) official. 

A document is approved by the ministry only if it is signed by at least one official from the M-th floor. An official signs a document only if at least one of the following conditions is satisfied: 
a. the official works on the 1st floor; 
b. the document is signed by the official working in the room with the same number but situated one floor below; 
c. the document is signed by an official working in a neighbouring room (rooms are neighbouring if they are situated on the same floor and their numbers differ by one).

Each official collects a fee for signing a document. The fee is a positive integer not exceeding 10^9. 

You should find the cheapest way to approve the document. 


Input

The first line of an input file contains two integers, separated by space. The first integer M represents the number of floors in the building, and the second integer N represents the number of rooms per floor. Each of the next M lines contains N integers separated with spaces that describe fees (the k-th integer at l-th line is the fee required by the official working in the k-th room at the l-th floor).

Output

You should print the numbers of rooms (one per line) in the order they should be visited to approve the document in the cheapest way. If there are more than one way leading to the cheapest cost you may print an any of them.

Sample Input

3 4
10 10 1 10
2 2 2 10
1 10 10 10

Sample Output

3
3
2
1
1

Hint

You can assume that for each official there always exists a way to get the approval of a document (from the 1st floor to this official inclusively) paying no more than 10^9. 
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source

题目大意:从第一行任意位置开始走到最后一行任意位置。只能向下向左向右走。输出最短的路径中每一步所在的列数。
动态转移方程
1、因为可以向左向右移动,所以要循环两次,分别朝两个方向。
2、dp[ i ][ j ]表示从最后一行到第 i 行第 j 列这个位置用到的最少花费
3、dp[ i ][ j ]=min(dp[ i - 1 ][ j ] + a[ i ][ j ] , dp[ i ][ j - 1 ] + a[ i ][ j ] , dp[ i ][ j + 1 ] + a[ i ][ j ] )
4、用p[ ]数组存储每一次的状态,方便输出
AC代码
#include<cstdio>
#include<iostream>
using namespace std;
int f[105][505],dp[105][505];
int p[105][505];
int main(){
	int n,m;
	scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++){
		for(int j=1;j<=m;j++){
			scanf("%d",&f[i][j]);
		}
	}
	for(int i=n;i>=1;i--){
		for(int j=1;j<=m;j++){
			dp[i][j]=dp[i+1][j]+f[i][j];
			p[i][j]=j;
			if(j>1&&dp[i][j-1]+f[i][j]<dp[i][j])
			{
				dp[i][j]=dp[i][j-1]+f[i][j];
				p[i][j]=j-1;
			}
		}
		for(int j=m-1;j>=1;j--){
			if(j<m&&dp[i][j+1]+f[i][j]<dp[i][j])
			{
				dp[i][j]=dp[i][j+1]+f[i][j];
				p[i][j]=j+1;
			}
		}
	}
	int count=0;
	dp[1][count]=1999999999;
	for(int i=1;i<=m;i++){
		if(dp[1][i]<dp[1][count])count=i;
	}
	int i=1;
	while(i<=n){
		printf("%d\n",count);
		if(p[i][count]==count){
			i++;
		}
		else count=p[i][count];
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值