HDOJ 题目1709 The Balance(母函数)

The Balance

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5756    Accepted Submission(s): 2338


Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.
 

Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.
 

Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
 

Sample Input
  
  
3 1 2 4 3 9 2 1
 

Sample Output
  
  
0 2 4 5
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1721  1710  1707  1792  1714 
 
思路: 题意:
给出一些砝码,可以放在天秤的两边,问有[1,sum]中有哪些重量是不可称出来的
题解:
母函数,这里比较特殊的一点是砝码可以放在天枰的左右两端,我们可以在c2[j+k]+=c1[j]
后加多一句c2[abs(j-k)]+=c[j]...即可,假设原来的砝码都放在右端,则可以把新加的砝码放在左端,得到新重量。
ac代码
#include<stdio.h>
#include<string.h>
#include<math.h>
int c1[100010],c2[100010],a[100010],b[100010];
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int i,j,k,sum=0,c=0,end;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			sum+=a[i];
		}
		memset(c1,0,sizeof(c1));
		memset(c2,0,sizeof(c2));
		c1[0]=c1[a[0]]=1;
	//	end=a[0];
		for(i=2;i<=n;i++)
		{
			for(j=0;j<=sum;j++)
			{
				for(k=0;k<=a[i-1]&&k+j<=sum;k+=a[i-1])
				{
					c2[j+k] +=c1[j];
					c2[abs(j-k)] +=c1[j];
				}
			}
			//end+=a[i-1];
			for(j=0;j<=sum;j++)
			{
				c1[j]=c2[j];
				c2[j]=0;
			}
		}
		for(i=0;i<=sum;i++)
		{
			if(c1[i]==0)
			{
				b[c++]=i;
			}
		}
		if(!c)
		{
			printf("0\n");
			continue;
		}
		printf("%d\n",c);
		for(i=0;i<c;i++)
		{
			if(!i)
				printf("%d",b[i]);
			else
				printf(" %d",b[i]);
		}
		printf("\n");
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值